summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2019-07-05 20:40:49 -0500
committerGitHub <noreply@github.com>2019-07-05 20:40:49 -0500
commit1e71ddfb9ac9e368c9f99d351ae7954fb502663e (patch)
tree856648156a3fdf6083d4c0530c41421efb533aa8 /src/CMakeLists.txt
parent2c289524f23a2ec481224b2ea569397acbb5e39e (diff)
Refactor strings to use an inference manager object (#3076)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 885b26078..cc13dec6d 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -628,6 +628,8 @@ libcvc4_add_sources(
theory/shared_terms_database.h
theory/sort_inference.cpp
theory/sort_inference.h
+ theory/strings/inference_manager.cpp
+ theory/strings/inference_manager.h
theory/strings/normal_form.cpp
theory/strings/normal_form.h
theory/strings/regexp_elim.cpp
@@ -645,6 +647,8 @@ libcvc4_add_sources(
theory/strings/theory_strings_rewriter.cpp
theory/strings/theory_strings_rewriter.h
theory/strings/theory_strings_type_rules.h
+ theory/strings/theory_strings_utils.cpp
+ theory/strings/theory_strings_utils.h
theory/strings/type_enumerator.h
theory/subs_minimize.cpp
theory/subs_minimize.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback