summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2020-05-22 06:41:50 -0700
committerGitHub <noreply@github.com>2020-05-22 08:41:50 -0500
commitc531152e6a707b66b885e508ea61e2a67e195ccc (patch)
treea18a2d342b03db1700a963470f2064cf3ac8d086 /src/CMakeLists.txt
parentae33f11d0f4156b4d21b9e77f6df59ec0f9e8184 (diff)
Add support for SAT solver Kissat. (#4514)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 66a1fee16..ff11897e9 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -190,6 +190,8 @@ libcvc4_add_sources(
prop/cnf_stream.h
prop/cryptominisat.cpp
prop/cryptominisat.h
+ prop/kissat.cpp
+ prop/kissat.h
prop/minisat/core/Dimacs.h
prop/minisat/core/Solver.cc
prop/minisat/core/Solver.h
@@ -841,6 +843,10 @@ if(USE_CRYPTOMINISAT)
target_link_libraries(cvc4 ${CryptoMiniSat_LIBRARIES})
target_include_directories(cvc4 PRIVATE ${CryptoMiniSat_INCLUDE_DIR})
endif()
+if(USE_KISSAT)
+ target_link_libraries(cvc4 ${Kissat_LIBRARIES})
+ target_include_directories(cvc4 PRIVATE ${Kissat_INCLUDE_DIR})
+endif()
if(USE_DRAT2ER)
target_link_libraries(cvc4 ${Drat2Er_LIBRARIES})
target_include_directories(cvc4 PRIVATE ${Drat2Er_INCLUDE_DIR})
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback