summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2020-04-10 19:15:18 -0500
committerGitHub <noreply@github.com>2020-04-10 19:15:18 -0500
commit04a8bf833bad57329a4e83b3c5aafb7537de885d (patch)
tree07d3e46c8da90c8b23475712deb93b39765dc047 /src/CMakeLists.txt
parent6b599f87b18186b811f187789e48c1e8c0774534 (diff)
Split the non-linear solver (#4219)
This splits the "non-linear solver" from "NonlinearExtension". The non-linear solver is the module that implements the inference schemas whereas NonlinearExtension is the glue code that manages the solver(s) for non-linear. This also involves moving utilities from the non-linear solver to their own file.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index dec5a7f16..5284aa12c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -298,10 +298,16 @@ libcvc4_add_sources(
theory/arith/linear_equality.h
theory/arith/matrix.cpp
theory/arith/matrix.h
+ theory/arith/nl_constraint.cpp
+ theory/arith/nl_constraint.h
theory/arith/nl_lemma_utils.cpp
theory/arith/nl_lemma_utils.h
theory/arith/nl_model.cpp
theory/arith/nl_model.h
+ theory/arith/nl_monomial.cpp
+ theory/arith/nl_monomial.h
+ theory/arith/nl_solver.cpp
+ theory/arith/nl_solver.h
theory/arith/nonlinear_extension.cpp
theory/arith/nonlinear_extension.h
theory/arith/normal_form.cpp
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback