summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <gereon.kremer@cs.rwth-aachen.de>2020-08-04 12:57:34 +0200
committerGitHub <noreply@github.com>2020-08-04 05:57:34 -0500
commit4844afa3d254bdabac397556e166a2534bb6c2ac (patch)
tree1da4a957cf073c25c6cfc9a7393afe29a1b14b3b /src/CMakeLists.txt
parentc84db77ecdaa7107a33824484bf9c649f8fcbbff (diff)
Add CAD-based solver (#4834)
Based on #4774, this PR adds a new CadSolver class that allows the NonlinearExtension to actually employ the CAD-based method. In more detail: add --nl-cad option add CadSolver class that wraps cad::CDCAC with support for checks, model construction and conflict generation add new Inference types for the NlLemma class use CadSolver in NonlinearExtension (if --nl-cad is given)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 17c4a26f5..cd6f48178 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -310,6 +310,8 @@ libcvc4_add_sources(
theory/arith/linear_equality.h
theory/arith/matrix.cpp
theory/arith/matrix.h
+ theory/arith/nl/cad_solver.cpp
+ theory/arith/nl/cad_solver.h
theory/arith/nl/cad/cdcac.cpp
theory/arith/nl/cad/cdcac.h
theory/arith/nl/cad/cdcac_utils.cpp
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback