summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <gereon.kremer@cs.rwth-aachen.de>2020-09-02 15:48:12 +0200
committerGitHub <noreply@github.com>2020-09-02 08:48:12 -0500
commit02e682821028bc704c57a762dadeb6f82bb70ebf (patch)
tree4eb20c4d3e6b06eaee58b808909e603da013b554 /src/CMakeLists.txt
parent78917e16f6521b0e8a074f3649fc6adf37614617 (diff)
Add ArithLemma and arith::InferenceManager (#4960)
This PR adds a new ArithLemma that is essentiall NlLemma, but derived from the new theory::Lemma and meant to be used all across the arithmetic theory. Also, based on theory::InferenceManagerBuffered this PR adds arith::InferenceManager that shall become the sole interface between the arithmetic theory and the OutputChannel.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7a383d0c8..2da04ce66 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -251,6 +251,8 @@ libcvc4_add_sources(
theory/arith/approx_simplex.h
theory/arith/arith_ite_utils.cpp
theory/arith/arith_ite_utils.h
+ theory/arith/arith_lemma.cpp
+ theory/arith/arith_lemma.h
theory/arith/arith_msum.cpp
theory/arith/arith_msum.h
theory/arith/arith_rewriter.cpp
@@ -287,6 +289,8 @@ libcvc4_add_sources(
theory/arith/fc_simplex.h
theory/arith/infer_bounds.cpp
theory/arith/infer_bounds.h
+ theory/arith/inference_manager.cpp
+ theory/arith/inference_manager.h
theory/arith/linear_equality.cpp
theory/arith/linear_equality.h
theory/arith/matrix.cpp
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback