summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2020-07-31 07:19:35 -0500
committerGitHub <noreply@github.com>2020-07-31 07:19:35 -0500
commit0f040cbc2b068d3f22f6d46ec35aff3ab720ec28 (patch)
treef6ea30c27269d70774bc29e46473a0d8a8fbf21b /src/CMakeLists.txt
parent728b73212dad6a7ec0e2a6a97761f8bbaabee914 (diff)
Split listener classes from SmtEngine (#4816)
This moves listener classes owned by SmtEngine to their own file. The SmtEnginePrivate class previously what itself a NodeManagerListener. This class will be deleted. Instead a new NodeManagerListener is introduced here whose sole responsibility is to do the work required for node manager listening. Note I had to add a (temporary) friend relationship to SmtEngine, which will be removed in an upcoming PR to split the management of dumping to its own utility.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 59b559cb2..53d049411 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -230,6 +230,8 @@ libcvc4_add_sources(
smt/defined_function.h
smt/dump.cpp
smt/dump.h
+ smt/listeners.cpp
+ smt/listeners.h
smt/logic_exception.h
smt/logic_request.cpp
smt/logic_request.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback