summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2021-05-24 13:51:09 -0500
committerGitHub <noreply@github.com>2021-05-24 15:51:09 -0300
commitbd33d20609999f6f847aeb63a42350aeb3041406 (patch)
tree8b4a3ccb0ab48b65bd70222dbfd572de8743bcd9 /src/CMakeLists.txt
parent1516e3b5d9436be86841a52002fc728fcd52dd34 (diff)
Move proof utilities to src/proof/ (#6611)
This moves all generic proof utilites from src/expr/ and src/theory/ to src/proof/. It also changes the include for term conversion proof generator to conv_proof_generator in preparation to rename this utility on a followup PR (to avoid confusion with the use of "Term").
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt49
1 files changed, 41 insertions, 8 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 5362baad8..025f10117 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -136,9 +136,50 @@ libcvc5_add_sources(
printer/smt2/smt2_printer.h
printer/tptp/tptp_printer.cpp
printer/tptp/tptp_printer.h
+ proof/buffered_proof_generator.cpp
+ proof/buffered_proof_generator.h
+ proof/conv_proof_generator.cpp
+ proof/conv_proof_generator.h
+ proof/conv_seq_proof_generator.cpp
+ proof/conv_seq_proof_generator.h
proof/clause_id.h
proof/dot/dot_printer.cpp
proof/dot/dot_printer.h
+ proof/eager_proof_generator.cpp
+ proof/eager_proof_generator.h
+ proof/lazy_proof.cpp
+ proof/lazy_proof.h
+ proof/lazy_proof_chain.cpp
+ proof/lazy_proof_chain.h
+ proof/lazy_tree_proof_generator.cpp
+ proof/lazy_tree_proof_generator.h
+ proof/proof.cpp
+ proof/proof.h
+ proof/proof_checker.cpp
+ proof/proof_checker.h
+ proof/proof_ensure_closed.cpp
+ proof/proof_ensure_closed.h
+ proof/proof_generator.cpp
+ proof/proof_generator.h
+ proof/proof_node.cpp
+ proof/proof_node.h
+ proof/proof_node_algorithm.cpp
+ proof/proof_node_algorithm.h
+ proof/proof_node_to_sexpr.cpp
+ proof/proof_node_to_sexpr.h
+ proof/proof_node_manager.cpp
+ proof/proof_node_manager.h
+ proof/proof_node_updater.cpp
+ proof/proof_node_updater.h
+ proof/proof_rule.cpp
+ proof/proof_rule.h
+ proof/proof_set.h
+ proof/proof_step_buffer.cpp
+ proof/proof_step_buffer.h
+ proof/trust_node.cpp
+ proof/trust_node.h
+ proof/theory_proof_step_buffer.cpp
+ proof/theory_proof_step_buffer.h
proof/unsat_core.cpp
proof/unsat_core.h
prop/bv_sat_solver_notify.h
@@ -600,8 +641,6 @@ libcvc5_add_sources(
theory/decision_manager.h
theory/decision_strategy.cpp
theory/decision_strategy.h
- theory/eager_proof_generator.cpp
- theory/eager_proof_generator.h
theory/ee_manager.cpp
theory/ee_manager.h
theory/ee_manager_distributed.cpp
@@ -631,8 +670,6 @@ libcvc5_add_sources(
theory/inference_id.h
theory/inference_manager_buffered.cpp
theory/inference_manager_buffered.h
- theory/lazy_tree_proof_generator.cpp
- theory/lazy_tree_proof_generator.h
theory/logic_info.cpp
theory/logic_info.h
theory/model_manager.cpp
@@ -1029,14 +1066,10 @@ libcvc5_add_sources(
theory/theory_model_builder.h
theory/theory_preprocessor.cpp
theory/theory_preprocessor.h
- theory/theory_proof_step_buffer.cpp
- theory/theory_proof_step_buffer.h
theory/theory_rewriter.cpp
theory/theory_rewriter.h
theory/theory_state.cpp
theory/theory_state.h
- theory/trust_node.cpp
- theory/trust_node.h
theory/trust_substitutions.cpp
theory/trust_substitutions.h
theory/type_enumerator.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback