summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2021-04-20 21:34:35 -0500
committerGitHub <noreply@github.com>2021-04-21 02:34:35 +0000
commitfafde0249bec12df91370119f35fc020ec81c935 (patch)
tree889e5c2dca3e334ce2a4a2f52b28ee58b27025b9 /src/CMakeLists.txt
parent7730169aa938dfc8bf3991fcae1cc38344fad800 (diff)
Add basic utilities for new implementation of justification heuristic (#6333)
This sets up the core utilities for the new implementation of justification heuristic
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9e340a31c..82c556559 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -25,6 +25,12 @@ libcvc4_add_sources(
decision/decision_strategy.h
decision/justification_heuristic.cpp
decision/justification_heuristic.h
+ decision/justify_info.cpp
+ decision/justify_info.h
+ decision/justify_stack.cpp
+ decision/justify_stack.h
+ decision/justify_stats.cpp
+ decision/justify_stats.h
lib/clock_gettime.c
lib/clock_gettime.h
lib/ffs.c
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback