summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2021-05-04 19:25:25 -0500
committerGitHub <noreply@github.com>2021-05-04 19:25:25 -0500
commit8a7c43f82b17a444c2f9518bc27f4ea8afe21201 (patch)
tree12f66f7bde98f4855b06038d813b49829ea82509 /src/CMakeLists.txt
parent67c43a7294442a7c660a26faf230cd983b21117d (diff)
Move current decision engine to decision engine old (#6466)
The decision engine is the class that contains strategies for doing e.g. justification heuristic. The current implementation is hardcoded for the old implementation of justification heuristic. Since both implementations will be maintained in the short term, this splits the parts of DecisionEngine that are specific to the old implementation to a class DecisionEngineOld. It refactors the interface of DecisionEngine in a way that is compatible with both implementations.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index af206c14d..901897e83 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -24,6 +24,8 @@ libcvc5_add_sources(
decision/decision_attributes.h
decision/decision_engine.cpp
decision/decision_engine.h
+ decision/decision_engine_old.cpp
+ decision/decision_engine_old.h
decision/decision_strategy.h
decision/justification_heuristic.cpp
decision/justification_heuristic.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback