summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2019-12-17 13:43:44 -0800
committerGitHub <noreply@github.com>2019-12-17 13:43:44 -0800
commite9499c41f405df8b42fd9ae10004b1b91a869106 (patch)
treefa1475f43a3e61b8f6ffdcb903b65919eba28661 /src/CMakeLists.txt
parent9b2914ed9f7b14ecf535ffe9e1328d0fa042e072 (diff)
Generate code for options with modes. (#3561)
This commit adds support for code generation of options with modes (enums). From now on option enums can be specified in the corresponding *.toml files without the need of extra code. All option enums are now in the options namespace.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 0 insertions, 8 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e62507d8e..af29a761c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -894,19 +894,11 @@ install(FILES
${INCLUDE_INSTALL_DIR}/cvc4/expr)
install(FILES
options/argument_extender.h
- options/arith_heuristic_pivot_rule.h
- options/arith_propagation_mode.h
- options/arith_unate_lemma_mode.h
- options/datatypes_modes.h
options/language.h
options/option_exception.h
options/options.h
options/printer_modes.h
- options/quantifiers_modes.h
options/set_language.h
- options/smt_modes.h
- options/sygus_out_mode.h
- options/theoryof_mode.h
DESTINATION
${INCLUDE_INSTALL_DIR}/cvc4/options)
install(FILES
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback