summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <nafur42@gmail.com>2021-10-12 09:37:51 -0700
committerGitHub <noreply@github.com>2021-10-12 16:37:51 +0000
commit2cd8877eef8505c868057e4d9fa087542ed46eff (patch)
tree35847c295e991994fecdf171cf3511bd78db37b2 /src/CMakeLists.txt
parent6094c2e2e43d2e6716f35689654d4915a6a1f4fc (diff)
Fix glpk, add antlr.so (#7341)
This PR makes the cmake integration of GLPK compatible with cmake 3.9. Also, it adds a missing BUILD_BYPRODUCT for antlr.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c00e92c83..52f2f2065 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1397,8 +1397,12 @@ if(USE_KISSAT)
endif()
endif()
if(USE_GLPK)
+ target_include_directories(cvc5-obj PRIVATE ${GLPK_INCLUDE_DIR})
+ target_link_libraries(cvc5-shared PRIVATE ${GLPK_LIBRARIES})
+ if(ENABLE_STATIC_LIBRARY)
+ target_link_libraries(cvc5-static PUBLIC ${GLPK_LIBRARIES})
+ endif()
target_link_libraries(cvc5-obj PUBLIC ${GLPK_LIBRARIES})
- target_include_directories(cvc5-obj PUBLIC ${GLPK_INCLUDE_DIR})
endif()
if(USE_POLY)
add_dependencies(cvc5-obj Polyxx_SHARED)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback