summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <gereon.kremer@cs.rwth-aachen.de>2021-03-31 23:17:38 +0200
committerGitHub <noreply@github.com>2021-03-31 21:17:38 +0000
commitf9a9af855fb65804ff0b36e764ccd9d0fa9f87f8 (patch)
tree2c90b0e704366541187198231102b2d1eed26f41 /src/CMakeLists.txt
parent39ea1d8a1497a83d1efc649bd10da82916e5db5f (diff)
Refactor GMP and Poly dependencies (#6245)
Refactors GMP and libpoly to also use external projects and be available within cmake as proper targets.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 78236f989..2679f6072 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1148,8 +1148,7 @@ if(USE_GLPK)
target_include_directories(cvc4 PRIVATE ${GLPK_INCLUDE_DIR})
endif()
if(USE_POLY)
- target_link_libraries(cvc4 PRIVATE ${POLY_LIBRARIES})
- target_include_directories(cvc4 PRIVATE ${POLY_INCLUDE_DIR})
+ target_link_libraries(cvc4 PRIVATE Polyxx)
endif()
if(USE_SYMFPU)
target_link_libraries(cvc4 PRIVATE SymFPU)
@@ -1157,8 +1156,7 @@ endif()
# Note: When linked statically GMP needs to be linked after CLN since CLN
# depends on GMP.
-target_link_libraries(cvc4 PRIVATE ${GMP_LIBRARIES})
-target_include_directories(cvc4 PRIVATE $<BUILD_INTERFACE:${GMP_INCLUDE_DIR}>)
+target_link_libraries(cvc4 PRIVATE GMP)
# Add rt library
# Note: For glibc < 2.17 we have to additionally link against rt (man clock_gettime).
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback