summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2020-03-20 14:07:37 -0500
committerGitHub <noreply@github.com>2020-03-20 14:07:37 -0500
commit964760cf81eb7414a11bbd89ef3a16e8927d6947 (patch)
tree0c574e99433c722e69af6efeeefbe0901010f7b7 /src/CMakeLists.txt
parentaa44c35f035f1cab03de0c5fe7c0f16b20f44696 (diff)
Split string-specific operators from TheoryStringsRewriter (#3920)
Organization towards theory of sequences. The motivation of this PR is to ensure that string-specific operators in the rewriter are in their own file; thus the use of mkConst<String> / getConst<String> is allowable in rewriter_str.cpp.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7e31d1494..c35a14800 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -679,18 +679,20 @@ libcvc4_add_sources(
theory/strings/regexp_operation.h
theory/strings/regexp_solver.cpp
theory/strings/regexp_solver.h
+ theory/strings/sequences_rewriter.cpp
+ theory/strings/sequences_rewriter.h
theory/strings/skolem_cache.cpp
theory/strings/skolem_cache.h
theory/strings/solver_state.cpp
theory/strings/solver_state.h
theory/strings/strings_fmf.cpp
theory/strings/strings_fmf.h
+ theory/strings/strings_rewriter.cpp
+ theory/strings/strings_rewriter.h
theory/strings/theory_strings.cpp
theory/strings/theory_strings.h
theory/strings/theory_strings_preprocess.cpp
theory/strings/theory_strings_preprocess.h
- theory/strings/theory_strings_rewriter.cpp
- theory/strings/theory_strings_rewriter.h
theory/strings/theory_strings_type_rules.h
theory/strings/theory_strings_utils.cpp
theory/strings/theory_strings_utils.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback