summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2020-09-08 20:36:08 -0500
committerGitHub <noreply@github.com>2020-09-08 20:36:08 -0500
commit1d3bb6048085342e2d85bf5193367afcd96885fa (patch)
treeb09c504cf13862f6286133130063bcfb57050556 /src/CMakeLists.txt
parent2786ba1efc7d420b5eda5389edffe72b676de32b (diff)
Split term registry from theory state in sets (#5037)
Currently, the theory state object SolverState in sets sends lemmas and has a reference to the parent theory. This PR is work towards eliminating these dependencies. This adds a TermRegistry object which is responsible for some of the tasks currently done by SolverState, including all those involving lemmas. Notice this also makes a bug fix in getUnivSetEqClass where the universe set was being returned instead of its representative. A followup PR will make SolverState maintain SAT-context-dependent membership lists which is also required for breaking the dependence on the parent theory.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6cd2c24d1..5a06df28b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -709,6 +709,8 @@ libcvc4_add_sources(
theory/sets/skolem_cache.h
theory/sets/solver_state.cpp
theory/sets/solver_state.h
+ theory/sets/term_registry.cpp
+ theory/sets/term_registry.h
theory/sets/theory_sets.cpp
theory/sets/theory_sets.h
theory/sets/theory_sets_private.cpp
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback