summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Ozdemir <aozdemir@hmc.edu>2018-12-03 11:56:47 -0800
committerGitHub <noreply@github.com>2018-12-03 11:56:47 -0800
commitaa0a875dfd40bd9dfa810238327db51498b74677 (patch)
tree5606b1214ef8388b86e964213ed3b9c67254317f /src/CMakeLists.txt
parent2a19474cdb6761fd4c9aeb0165e661c531ba3e38 (diff)
Bit vector proof superclass (#2599)
* Split BitvectorProof into a sub/superclass The superclass contains general printing knowledge. The subclass contains CNF or Resolution-specific knowledge. * Renames & code moves * Nits cleaned in prep for PR * Moved CNF-proof from ResolutionBitVectorProof to BitVectorProof Since DRAT BV proofs will also contain a CNF-proof, the CNF proof should be stored in `BitVectorProof`. * Unique pointers, comments, and code movement. Adjusted the distribution of code between BVP and RBVP. Notably, put the CNF proof in BVP because it isn't resolution-specific. Added comments to the headers of both files -- mostly BVP. Changed two owned pointers into unique_ptr. BVP's pointer to a CNF proof RBVP's pointer to a resolution proof BVP: `BitVectorProof` RBVP: `ResolutionBitVectorProof` * clang-format * Undo manual copyright modification * s/superclass/base class/ Co-Authored-By: alex-ozdemir <aozdemir@hmc.edu> * make LFSCBitVectorProof::printOwnedSort public * Andres's Comments Mostly cleaning up (or trying to clean up) includes. * Cleaned up one header cycle However, this only allowed me to move the forward-decl, not eliminate it, because there were actually two underlying include cycles that the forward-decl solved. * Added single _s to header gaurds * Fix Class name in debug output Credits to Andres Co-Authored-By: alex-ozdemir <aozdemir@hmc.edu> * Reordered methods in BitVectorProof per original ordering
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9a1cfe9e7..9e93bd953 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -142,6 +142,8 @@ libcvc4_add_sources(
proof/proof_output_channel.h
proof/proof_utils.cpp
proof/proof_utils.h
+ proof/resolution_bitvector_proof.cpp
+ proof/resolution_bitvector_proof.h
proof/sat_proof.h
proof/sat_proof_implementation.h
proof/simplify_boolean_node.cpp
@@ -202,6 +204,7 @@ libcvc4_add_sources(
prop/sat_solver.h
prop/sat_solver_factory.cpp
prop/sat_solver_factory.h
+ prop/bv_sat_solver_notify.h
prop/sat_solver_types.h
prop/theory_proxy.cpp
prop/theory_proxy.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback