summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2021-04-15 23:55:25 -0700
committerGitHub <noreply@github.com>2021-04-16 08:55:25 +0200
commit03c2724cef26fa20862634e25e3adc476d049db4 (patch)
treec89f442f907070abc2cf06ceb5636222167b8a74 /src/CMakeLists.txt
parentb7dcbee6f351c22ca3454d706d5773d01dd806fa (diff)
cmake: Build object libraries for base and context. (#6374)
cmake complains that the static base and context libraries are not exported as install targets. Since we do not want to install these libraries we'll build object libraries instead.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 2 insertions, 10 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e060ae43f..81105e817 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1092,25 +1092,17 @@ add_subdirectory(theory)
add_subdirectory(util)
#-----------------------------------------------------------------------------#
-# Build support library from base and context that can be used in the main
-# library as well as the parser library.
-
-add_library(cvc4support INTERFACE)
-target_link_libraries(cvc4support INTERFACE cvc4base)
-target_link_libraries(cvc4support INTERFACE cvc4context)
-
-#-----------------------------------------------------------------------------#
# All sources for libcvc4 are now collected in LIBCVC4_SRCS and (if generated)
# LIBCVC4_GEN_SRCS (via libcvc4_add_sources). We can now build libcvc4.
set_source_files_properties(${LIBCVC4_GEN_SRCS} PROPERTIES GENERATED TRUE)
-add_library(cvc4 ${LIBCVC4_SRCS} ${LIBCVC4_GEN_SRCS})
+add_library(cvc4 ${LIBCVC4_SRCS} ${LIBCVC4_GEN_SRCS}
+ $<TARGET_OBJECTS:cvc4base> $<TARGET_OBJECTS:cvc4context>)
target_include_directories(cvc4
PUBLIC
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
$<INSTALL_INTERFACE:include>
)
-target_link_libraries(cvc4 PRIVATE cvc4support)
include(GenerateExportHeader)
generate_export_header(cvc4)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback