summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2020-06-01 14:31:48 -0500
committerGitHub <noreply@github.com>2020-06-01 14:31:48 -0500
commit4ac66d3aee2a0571c169e4ce2d6049ea311462ce (patch)
tree27b16c3b6973dd9da6c54cd0dea2a89a16badfa6 /src/CMakeLists.txt
parenta6c8c9a293eca7cd753368d7f23f9978deb2b2d5 (diff)
Move non-linear files to src/theory/arith/nl (#4548)
Also makes CVC4::theory::arith::nl namespace. This includes some formatting changes.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt28
1 files changed, 14 insertions, 14 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e9be4dd3e..20e110b2b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -300,18 +300,20 @@ libcvc4_add_sources(
theory/arith/linear_equality.h
theory/arith/matrix.cpp
theory/arith/matrix.h
- theory/arith/nl_constraint.cpp
- theory/arith/nl_constraint.h
- theory/arith/nl_lemma_utils.cpp
- theory/arith/nl_lemma_utils.h
- theory/arith/nl_model.cpp
- theory/arith/nl_model.h
- theory/arith/nl_monomial.cpp
- theory/arith/nl_monomial.h
- theory/arith/nl_solver.cpp
- theory/arith/nl_solver.h
- theory/arith/nonlinear_extension.cpp
- theory/arith/nonlinear_extension.h
+ theory/arith/nl/nl_constraint.cpp
+ theory/arith/nl/nl_constraint.h
+ theory/arith/nl/nl_lemma_utils.cpp
+ theory/arith/nl/nl_lemma_utils.h
+ theory/arith/nl/nl_model.cpp
+ theory/arith/nl/nl_model.h
+ theory/arith/nl/nl_monomial.cpp
+ theory/arith/nl/nl_monomial.h
+ theory/arith/nl/nl_solver.cpp
+ theory/arith/nl/nl_solver.h
+ theory/arith/nl/nonlinear_extension.cpp
+ theory/arith/nl/nonlinear_extension.h
+ theory/arith/nl/transcendental_solver.cpp
+ theory/arith/nl/transcendental_solver.h
theory/arith/normal_form.cpp
theory/arith/normal_form.h
theory/arith/partial_model.cpp
@@ -332,8 +334,6 @@ libcvc4_add_sources(
theory/arith/theory_arith_private.h
theory/arith/theory_arith_private_forward.h
theory/arith/theory_arith_type_rules.h
- theory/arith/transcendental_solver.cpp
- theory/arith/transcendental_solver.h
theory/arith/type_enumerator.h
theory/arrays/array_info.cpp
theory/arrays/array_info.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback