summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2021-04-05 19:31:28 -0700
committerGitHub <noreply@github.com>2021-04-05 19:31:28 -0700
commitd2e454e0dfc06e16fe0a4228168b21cf1311fc35 (patch)
tree65063161aa9e21348182b13251524c58b0ca49c5 /src/CMakeLists.txt
parent00a20b53ce998f52b18303a7a680e6a00acc098c (diff)
New C++ Api: Rename and move headers. (#6292)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6c2af8226..04ad27b5c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -13,9 +13,9 @@
libcvc4_add_sources(
api/checks.h
- api/cvc4cpp.cpp
- api/cvc4cpp.h
- api/cvc4cppkind.h
+ api/cpp/cvc5.cpp
+ api/cpp/cvc5.h
+ api/cpp/cvc5_kind.h
context/backtrackable.h
context/cddense_set.h
context/cdhashmap.h
@@ -1182,14 +1182,14 @@ endif()
# Install public API headers
install(FILES
- api/cvc4cpp.h
- api/cvc4cppkind.h
+ api/cpp/cvc5.h
+ api/cpp/cvc5_kind.h
DESTINATION
- ${CMAKE_INSTALL_INCLUDEDIR}/cvc4/api)
+ ${CMAKE_INSTALL_INCLUDEDIR}/cvc5/)
install(FILES
${CMAKE_CURRENT_BINARY_DIR}/cvc4_export.h
DESTINATION
- ${CMAKE_INSTALL_INCLUDEDIR}/cvc4/)
+ ${CMAKE_INSTALL_INCLUDEDIR}/cvc5/)
# Fix include paths for all public headers.
# Note: This is a temporary fix until the new C++ API is in place.
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback