summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2019-07-01 15:23:15 -0500
committerGitHub <noreply@github.com>2019-07-01 15:23:15 -0500
commit084ccdd6f05781decad5f9faee60249216183ce5 (patch)
tree75a60e771a228f108626a905e67757d7fb30c20e /src/CMakeLists.txt
parent3777d6c940818a8085dbcc7a83f6d82adf4ced0f (diff)
Add higher-order elimination preprocessing pass (#2865)
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 011ba6ab5..f79c82d49 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -60,6 +60,8 @@ libcvc4_add_sources(
preprocessing/passes/extended_rewriter_pass.h
preprocessing/passes/global_negate.cpp
preprocessing/passes/global_negate.h
+ preprocessing/passes/ho_elim.cpp
+ preprocessing/passes/ho_elim.h
preprocessing/passes/int_to_bv.cpp
preprocessing/passes/int_to_bv.h
preprocessing/passes/ite_removal.cpp
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback