summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Reynolds <andrew.j.reynolds@gmail.com>2020-08-05 14:14:23 -0500
committerGitHub <noreply@github.com>2020-08-05 14:14:23 -0500
commitd8d3c55afc94482fc05f68ba6be47f767ab3b5c6 (patch)
treeea726e13c98562e9216f2b32f8c82c0add872d9a /src/CMakeLists.txt
parent47f003828a8ba0cd8edd362accaef8b2449b0c46 (diff)
Split Assertions from SmtEngine (#4788)
This splits all things related to storing assertions in the SmtEngine into a separate class "Assertions". It also converts the interface for its methods from Expr to Node.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cd6f48178..92f197252 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -223,6 +223,8 @@ libcvc4_add_sources(
smt/abduction_solver.h
smt/abstract_values.cpp
smt/abstract_values.h
+ smt/assertions.cpp
+ smt/assertions.h
smt/command.cpp
smt/command.h
smt/defined_function.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback