summaryrefslogtreecommitdiff
path: root/examples/sets-translate/Makefile.am
diff options
context:
space:
mode:
authorKshitij Bansal <kshitij@cs.nyu.edu>2014-05-29 20:13:52 -0400
committerKshitij Bansal <kshitij@cs.nyu.edu>2014-06-06 15:40:36 -0400
commit5c42662fe5cea3051341c8292202357e2a5e7dd3 (patch)
tree94aa636b95c7a81594a3d82f236263c91b0f6d0f /examples/sets-translate/Makefile.am
parent0dce010bea47bc6a318eece2bd92ed2305b64c21 (diff)
Sets translate, and other short fixes
- $ is a simple symbol is smt2. - ever found yourself counting in kind.h? no longer. - expose parser "logic is set" state for smt/smt2 (any better way?) - a more helpful assertion message in smt_engine
Diffstat (limited to 'examples/sets-translate/Makefile.am')
-rw-r--r--examples/sets-translate/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/examples/sets-translate/Makefile.am b/examples/sets-translate/Makefile.am
new file mode 100644
index 000000000..40b79e998
--- /dev/null
+++ b/examples/sets-translate/Makefile.am
@@ -0,0 +1,19 @@
+AM_CPPFLAGS = \
+ -I@srcdir@/../../src/include -I@srcdir@/../../src -I@builddir@/../../src $(ANTLR_INCLUDES)
+AM_CXXFLAGS = -Wall
+AM_CFLAGS = -Wall
+
+noinst_PROGRAMS = \
+ sets_translate
+
+noinst_DATA =
+
+sets_translate_SOURCES = \
+ sets_translate.cpp
+sets_translate_LDADD = \
+ @builddir@/../../src/parser/libcvc4parser.la \
+ @builddir@/../../src/libcvc4.la
+
+# for installation
+examplesdir = $(docdir)/$(subdir)
+examples_DATA = $(DIST_SOURCES) $(EXTRA_DIST)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback