summaryrefslogtreecommitdiff
path: root/examples/nra-translate/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2018-09-12 17:59:57 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commitdfdacd1fb241c08569cc20b2287c6aedc6b76d6a (patch)
tree3b3e3482b6e192456a2913251571b5908312ac09 /examples/nra-translate/CMakeLists.txt
parentaa86e978469e75691bd8f83e4a9fedd07aec283c (diff)
cmake: Added target examples (currently .cpp examples only)
Diffstat (limited to 'examples/nra-translate/CMakeLists.txt')
-rw-r--r--examples/nra-translate/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/examples/nra-translate/CMakeLists.txt b/examples/nra-translate/CMakeLists.txt
index e69de29bb..0d20e9fed 100644
--- a/examples/nra-translate/CMakeLists.txt
+++ b/examples/nra-translate/CMakeLists.txt
@@ -0,0 +1,6 @@
+set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin/examples/nra-translate)
+
+foreach(example ${CVC4_EXAMPLES_NRA_TRANSLATE})
+ add_executable(${example} EXCLUDE_FROM_ALL ${example}.cpp)
+ target_link_libraries(${example} cvc4 cvc4parser)
+endforeach()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback