summaryrefslogtreecommitdiff
path: root/examples/api/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-11-30 23:07:19 +0000
committerMorgan Deters <mdeters@gmail.com>2012-11-30 23:07:19 +0000
commit45229fd903afa592deb0499027375bc1d5562cbc (patch)
tree67b54b4841b1d084b90226cc5670c4c18173d06c /examples/api/Makefile.am
parent2bd85df6be705aed37a5d5eba082fbb9a38ab7c5 (diff)
all API examples now have java versions too; bitvectors gets built; also updated old-style copyrights in the examples
Diffstat (limited to 'examples/api/Makefile.am')
-rw-r--r--examples/api/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/examples/api/Makefile.am b/examples/api/Makefile.am
index 9e4e4470e..33775fd2a 100644
--- a/examples/api/Makefile.am
+++ b/examples/api/Makefile.am
@@ -1,3 +1,5 @@
+SUBDIRS = . java
+
AM_CPPFLAGS = \
-I@srcdir@/../../src/include -I@srcdir@/../../src -I@builddir@/../../src $(ANTLR_INCLUDES)
AM_CXXFLAGS = -Wall
@@ -6,7 +8,8 @@ AM_CFLAGS = -Wall
noinst_PROGRAMS = \
linear_arith \
helloworld \
- combination
+ combination \
+ bitvectors
noinst_DATA =
@@ -27,6 +30,11 @@ helloworld_SOURCES = \
helloworld_LDADD = \
@builddir@/../../src/libcvc4.la
+bitvectors_SOURCES = \
+ bitvectors.cpp
+bitvectors_LDADD = \
+ @builddir@/../../src/libcvc4.la
+
# for installation
examplesdir = $(docdir)/$(subdir)
examples_DATA = $(DIST_SOURCES) $(EXTRA_DIST)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback