summaryrefslogtreecommitdiff
path: root/examples/api/Makefile.am
diff options
context:
space:
mode:
authorTim King <taking@cs.nyu.edu>2012-11-28 22:59:58 +0000
committerTim King <taking@cs.nyu.edu>2012-11-28 22:59:58 +0000
commit91673d6cefa63bc0f706101946e0c01fcd429071 (patch)
tree8fa80213fb916675f37f4a1a1bcd431bcc017f7f /examples/api/Makefile.am
parentf0ebc08cf865d654a6d7ca4361775db8a64b1f62 (diff)
Adding the helloworld.cpp example.
Diffstat (limited to 'examples/api/Makefile.am')
-rw-r--r--examples/api/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/examples/api/Makefile.am b/examples/api/Makefile.am
new file mode 100644
index 000000000..937a76d36
--- /dev/null
+++ b/examples/api/Makefile.am
@@ -0,0 +1,26 @@
+AM_CPPFLAGS = \
+ -I@srcdir@/../../src/include -I@srcdir@/../../src -I@builddir@/../../src $(ANTLR_INCLUDES)
+AM_CXXFLAGS = -Wall
+AM_CFLAGS = -Wall
+
+noinst_PROGRAMS = \
+ linear_arith \
+ helloworld
+
+
+noinst_DATA =
+
+linear_arith_SOURCES = \
+ linear_arith.cpp
+linear_arith_LDADD = \
+ @builddir@/../../src/libcvc4.la
+
+
+helloworld_SOURCES = \
+ helloworld.cpp
+helloworld_LDADD = \
+ @builddir@/../../src/libcvc4.la
+
+# for installation
+examplesdir = $(docdir)/$(subdir)
+examples_DATA = $(DIST_SOURCES) $(EXTRA_DIST)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback