summaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2018-10-08 17:34:35 -0700
committerGitHub <noreply@github.com>2018-10-08 17:34:35 -0700
commit55acdeb493ee3f9b66ed38f7526670b6e66c46bd (patch)
tree7e3ca116f1a243adc93083e5016f422cfb316680 /examples/CMakeLists.txt
parentbd5f6d16dc88624a1dbf463f5d080bdc5af50494 (diff)
Cmake: Fix ctest call for example/translator. (#2600)
example/translator expects an input file to translate but none was provided in the ctest call. This caused the ctest call to hang and wait for input on stdin in some configurations (in particular in the nightlies).
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 33d341ac8..68eb06074 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -68,7 +68,9 @@ endmacro()
set(EXAMPLES_LINK_LIBS cvc4 cvc4parser)
cvc4_add_example(simple_vc_cxx "" "${EXAMPLES_LINK_LIBS}" "")
cvc4_add_example(simple_vc_quant_cxx "" "${EXAMPLES_LINK_LIBS}" "")
-cvc4_add_example(translator "" "${EXAMPLES_LINK_LIBS}" "")
+cvc4_add_example(translator "" "${EXAMPLES_LINK_LIBS}" ""
+ # argument to binary (for testing)
+ ${CMAKE_CURRENT_SOURCE_DIR}/translator-example-input.smt2)
if(BUILD_BINDINGS_JAVA)
find_package(Java REQUIRED)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback