summaryrefslogtreecommitdiff
path: root/docs/CMakeLists.txt
diff options
context:
space:
mode:
authorGereon Kremer <gereon.kremer@cs.rwth-aachen.de>2021-04-20 23:10:38 +0200
committerGitHub <noreply@github.com>2021-04-20 21:10:38 +0000
commit18ce14653647a93319cc53eec9bc310d3a4c6f57 (patch)
tree8cb8975f6a2823087c776171fa4bf6e4d61ada8d /docs/CMakeLists.txt
parenteee194ba0e228d28aa8bdd40a360b98fc3d0613f (diff)
Split C++ API docs from general docs (#6365)
Diffstat (limited to 'docs/CMakeLists.txt')
-rw-r--r--docs/CMakeLists.txt30
1 files changed, 3 insertions, 27 deletions
diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
index 01d7aed65..2890148b7 100644
--- a/docs/CMakeLists.txt
+++ b/docs/CMakeLists.txt
@@ -12,44 +12,20 @@
#
# The build system configuration.
##
-find_package(Doxygen REQUIRED)
find_package(Sphinx REQUIRED)
check_python_module(breathe)
-set(DOXYFILE_IN ${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in)
-set(DOXYFILE_OUT ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile)
-
-set(DOXYGEN_INPUT_DIR ${PROJECT_SOURCE_DIR}/src/api/cpp)
-set(DOXYGEN_OUTPUT_DIR ${CMAKE_CURRENT_BINARY_DIR}/doxygen)
-set(DOXYGEN_INPUT
- "${DOXYGEN_INPUT_DIR}/cvc5.h ${DOXYGEN_INPUT_DIR}/cvc5_kind.h")
-set(DOXYGEN_INDEX_FILE ${DOXYGEN_OUTPUT_DIR}/xml/index.xml)
-
-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in
- ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile @ONLY)
-
-file(MAKE_DIRECTORY ${DOXYGEN_OUTPUT_DIR})
-
-add_custom_command(OUTPUT ${DOXYGEN_INDEX_FILE}
- DEPENDS
- ${PROJECT_SOURCE_DIR}/src/api/cpp/cvc5.h
- ${PROJECT_SOURCE_DIR}/src/api/cpp/cvc5_kind.h
- COMMAND ${DOXYGEN_EXECUTABLE} ${DOXYFILE_OUT}
- WORKING_DIRECTORY ${DOXYGEN_BIN_DIR}
- MAIN_DEPENDENCY ${DOXYFILE_OUT} ${DOXYFILE_IN}
- COMMENT "Generating doxygen API docs")
-
-add_custom_target(docs-doxygen ALL DEPENDS ${DOXYGEN_INDEX_FILE})
+add_subdirectory(cpp)
set(SPHINX_INPUT_DIR ${CMAKE_CURRENT_SOURCE_DIR})
set(SPHINX_OUTPUT_DIR ${CMAKE_CURRENT_BINARY_DIR}/sphinx)
add_custom_target(docs ALL
- DEPENDS docs-doxygen
+ DEPENDS docs-cpp
COMMAND
${SPHINX_EXECUTABLE} -b html
# Tell Breathe where to find the Doxygen output
- -Dbreathe_projects.cvc5=${DOXYGEN_OUTPUT_DIR}/xml
+ -Dbreathe_projects.cvc5=${CPP_DOXYGEN_XML_FOLDER}
${SPHINX_INPUT_DIR} ${SPHINX_OUTPUT_DIR}
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
COMMENT "Generating Sphinx Api docs")
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback