summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormakaimann <makaim@stanford.edu>2017-05-12 12:47:16 -0700
committermakaimann <makaim@stanford.edu>2017-05-12 12:47:16 -0700
commit220d8a9cf8706bdf28162ff452f58f1262ba691d (patch)
tree1f24bcaf98d3c7384891337a4c5eacfa01605a63 /configure.ac
parent31681c7ff2a1469f5efc325fc1b3a406e3a85949 (diff)
Conditional coverage build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7da86d8a8..e94733576 100644
--- a/configure.ac
+++ b/configure.ac
@@ -720,6 +720,9 @@ AC_ARG_ENABLE([coverage],
if test -z "${enable_coverage+set}"; then
enable_coverage=no
+ # make COVERAGE_ON the empty string for makefile conditional function
+ # $(if $(COVERAGE_ON), action1, action2)
+ COVERAGE_ON=
fi
AC_MSG_RESULT([$enable_coverage])
@@ -730,6 +733,7 @@ if test "$enable_coverage" = yes; then
# If the user didn't specify these, we force them here. If the
# user specified them in opposite phase, give warnings that they
# shouldn't do that, or bomb out.
+ COVERAGE_ON=yes
if test "$user_specified_enable_or_disable_shared" != yes; then
enable_shared=no
AC_MSG_WARN([turning off shared library building due to --enable-coverage])
@@ -1263,6 +1267,7 @@ AC_SUBST(BUILDING_STATIC)
AC_SUBST(STATIC_BINARY)
AM_CONDITIONAL([STATIC_BINARY], [test "$enable_static_binary" = yes])
AM_CONDITIONAL([COVERAGE_ENABLED], [test "$enable_coverage" = yes])
+AC_SUBST([COVERAGE_ON])
AM_CONDITIONAL([CVC4_DEBUG], [test "$with_build" = debug])
AM_CONDITIONAL([CVC4_TRACING], [test "$enable_tracing" = yes])
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback