summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2009-11-20 20:10:43 +0000
committerMorgan Deters <mdeters@gmail.com>2009-11-20 20:10:43 +0000
commitcb56555734b5139f779e65cc6e628124ac6796e6 (patch)
tree50b61ea132c4a9340dcf2c5d0fbe3f15060f8e95 /configure.ac
parentcd98370b338a0cc5343067151884a06431a1d92c (diff)
fix to expr #includes; better test-environment configuration
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 57dde9b35..e569dc5ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,6 +68,15 @@ AC_ARG_VAR(TEST_CPPFLAGS, [CXXFLAGS to use when testing (default=$CPPFLAGS)])
AC_ARG_VAR(TEST_CXXFLAGS, [CXXFLAGS to use when testing (default=$CXXFLAGS)])
AC_ARG_VAR(TEST_LDFLAGS, [LDFLAGS to use when testing (default=$LDFLAGS)])
+if test -n "$CXXTEST"; then
+ AC_CHECK_PROG(PERL, perl, perl, [])
+ if test -z "$PERL"; then
+ AC_MSG_WARN([unit tests disabled, perl not found.])
+ CXXTESTGEN=
+ CXXTEST=
+ fi
+fi
+
# Checks for libraries.
AC_CHECK_LIB(gmp, __gmpz_init, , [AC_MSG_ERROR([GNU MP not found, see http://gmplib.org/])])
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback