summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-02-21 23:02:23 +0000
committerMorgan Deters <mdeters@gmail.com>2012-02-21 23:02:23 +0000
commit17cb8457875dbe3a9eb79312a9b6d158070f7224 (patch)
tree367e605d20146a503f25d3fdcf779b2f4100eb9f /configure.ac
parentc0377cdf4aad1e4d7b073c91887db91f357c6395 (diff)
add a "--with-portfolio" configure option that makes a missing boost-thread library an error; useful for builds requiring a "pcvc4" binary at the end
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 18 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 4b079facf..53790a090 100644
--- a/configure.ac
+++ b/configure.ac
@@ -857,18 +857,27 @@ AC_CHECK_DECLS([optreset], [], [], [#include <getopt.h>])
# look for boost library, but don't make it a fatal error if not found
cvc4_has_threads=maybe
-BOOST_REQUIRE([], [cvc4_has_threads=no])
-if test $cvc4_has_threads = no; then
- AC_MSG_WARN([disabling multithreaded support])
-else
- BOOST_THREADS
- if test -n "$BOOST_THREAD_LIBS"; then
- cvc4_has_threads=yes
- else
+cvc4_must_have_threads=no
+AC_ARG_WITH([portfolio],
+ AS_HELP_STRING([--with-portfolio], [build the multithreaded portfolio version of CVC4 (pcvc4)]),
+ [if test "$withval" = no; then cvc4_has_threads=no; elif test "$withval" = yes; then cvc4_must_have_threads=yes; fi])
+if test $cvc4_has_threads = maybe; then
+ BOOST_REQUIRE([], [cvc4_has_threads=no])
+ if test $cvc4_has_threads = no; then
AC_MSG_WARN([disabling multithreaded support])
- cvc4_has_threads=no
+ else
+ BOOST_THREADS
+ if test -n "$BOOST_THREAD_LIBS"; then
+ cvc4_has_threads=yes
+ else
+ AC_MSG_WARN([disabling multithreaded support])
+ cvc4_has_threads=no
+ fi
fi
fi
+if test $cvc4_has_threads = no -a $cvc4_must_have_threads = yes; then
+ AC_MSG_ERROR([user gave --with-threads but could not build with threads; maybe boost threading library is missing?])
+fi
# Whether to build compatibility library
CVC4_BUILD_LIBCOMPAT=yes
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback