summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndres Notzli <andres.noetzli@gmail.com>2017-03-08 02:50:56 -0800
committerAndres Notzli <andres.noetzli@gmail.com>2017-03-08 10:06:13 -0800
commitb36ffd6c40b0f037e780f71a2d5c10ff53cbee14 (patch)
tree5a8293c2cb55693f74418b794bd76125e7d1d052 /configure.ac
parentab68adfc44049598ee79a3c8b4379694d786d9aa (diff)
Fix MinGW-w64 build
This commit fixes configure.ac to try to get clock_gettime() from pthread. Without it, clock_gettime() is detected as missing at configuration time for MinGW-w64 but exists at compile time, which causes conflicts. Additionally, this commit updates the helper script for Windows to use MinGW-w64 by default instead of MinGW.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3d645b24e..d2c08661b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -999,7 +999,7 @@ fi
# Checks for libraries.
-AC_SEARCH_LIBS([clock_gettime], [rt],
+AC_SEARCH_LIBS([clock_gettime], [rt pthread],
[AC_DEFINE([HAVE_CLOCK_GETTIME], [1],
[Defined to 1 if clock_gettime() is supported by the platform.])],
[AC_LIBOBJ([clock_gettime])])
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback