summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim King <taking@cs.nyu.edu>2013-04-26 17:10:21 -0400
committerMorgan Deters <mdeters@cs.nyu.edu>2013-04-26 17:10:21 -0400
commit9098391fe334d829ec4101f190b8f1fa21c30752 (patch)
treeb134fc1fe1c767a50013e1449330ca6a7ee18a3d /configure.ac
parenta9174ce4dc3939bbe14c9aa1fd11c79c7877eb16 (diff)
FCSimplex branch merge
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2a48f4b13..deee4fa68 100644
--- a/configure.ac
+++ b/configure.ac
@@ -496,7 +496,7 @@ if test "$enable_static_binary" = yes; then
fi
fi
-AC_MSG_CHECKING([whether to support proof in libcvc4])
+AC_MSG_CHECKING([whether to support proofs in libcvc4])
AC_ARG_ENABLE([proof],
[AS_HELP_STRING([--enable-proof],
@@ -708,6 +708,17 @@ if test "$enable_profiling" = yes; then
CVC4LDFLAGS="${CVC4LDFLAGS:+$CVC4LDFLAGS }-pg"
fi
+# Check for libglpk (defined in config/glpk.m4)
+AC_ARG_WITH([glpk],
+ [AS_HELP_STRING([--with-glpk],
+ [use GLPK simplex solver])], [], [with_glpk=])
+CVC4_CHECK_FOR_GLPK
+if test $have_libglpk -eq 1; then
+ CVC4CPPFLAGS="${CVC4CPPFLAGS:+$CVC4CPPFLAGS }-DCVC4_USE_GLPK"
+fi
+AM_CONDITIONAL([CVC4_USE_GLPK], [test $have_libglpk -eq 1])
+AC_SUBST([GLPK_LIBS])
+
# Check to see if this version/architecture of GNU C++ explicitly
# instantiates __gnu_cxx::hash<uint64_t> or not. Some do, some don't.
# See src/util/hash.h.
@@ -1312,6 +1323,7 @@ TLS support : $CVC4_TLS_explanation
Portfolio : $with_portfolio
MP library : $mplibrary
+GLPK : $with_glpk
CPPFLAGS : $CPPFLAGS
CXXFLAGS : $CXXFLAGS
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback