summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristopher L. Conway <christopherleeconway@gmail.com>2010-04-01 03:02:01 +0000
committerChristopher L. Conway <christopherleeconway@gmail.com>2010-04-01 03:02:01 +0000
commit5f92777db6265321759f463e6c703111cdfc9a80 (patch)
tree8aa2569053a081ebaac598fd1ff083489290ba64 /configure.ac
parentc5262c36c1a6a3b5e879ce6eac3f6acb976172d7 (diff)
Adding check for --disable-shared on --enable-coverage
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 985a26903..ecaa1bf30 100644
--- a/configure.ac
+++ b/configure.ac
@@ -317,6 +317,12 @@ fi
AC_MSG_RESULT([$enable_coverage])
if test "$enable_coverage" = yes; then
+dnl TODO: Is there someway to detect if enable_shared is set by default,
+dnl so that we can automatically disable shared and enable static?
+ if test "$enable_shared" = yes; then
+ AC_MSG_ERROR([Gcov requires static libraries. Use --disable-shared.])
+ fi
+
CVC4CPPFLAGS="$CVC4CPPFLAGS -DCVC4_COVERAGE"
CVC4CXXFLAGS="$CVC4CXXFLAGS --coverage"
CVC4LDFLAGS="$CVC4LDFLAGS --coverage"
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback