summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-06-18 23:09:29 +0000
committerMorgan Deters <mdeters@gmail.com>2010-06-18 23:09:29 +0000
commit498bb02fc7d2539d41b778bc42e383ca8dbf6d9e (patch)
treea4192c19dd6f28a2547b647ffb1a385ac3e7b802 /configure.ac
parentfd6af9181e763cd9564245114cfa47f3952484db (diff)
"statistics" and "staticbinary" are now tags on the build (so you get build directories like builds/x86_64-unknown-linux-gnu/debug-staticbinary-nostatistics .. etc. This is useful to distinguish static binary builds and statistics builds from each other when you configure multiple times in the same source directory
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 19 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 28a5cca7a..005718287 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,6 +62,10 @@ AC_CANONICAL_BUILD
AC_CANONICAL_HOST
AC_CANONICAL_TARGET
+if test "$enable_shared" = no -a "$enable_static" = yes; then
+ enable_static_binary=yes
+fi
+
# Features requested by the user
AC_MSG_CHECKING([for requested build profile])
AC_ARG_WITH([build],
@@ -84,6 +88,13 @@ if test -n "${enable_optimized+set}"; then
btargs="$btargs nooptimized"
fi
fi
+if test -n "${enable_static_binary+set}"; then
+ if test "$enable_static_binary" = yes; then
+ btargs="$btargs staticbinary"
+ else
+ btargs="$btargs nostaticbinary"
+ fi
+fi
if test -n "${enable_debug_symbols+set}"; then
if test "$enable_debug_symbols" = yes; then
btargs="$btargs debugsymbols"
@@ -219,9 +230,9 @@ case "$with_build" in
FLAG_VISIBILITY_HIDDEN=
if test -z "${enable_optimized+set}" ; then enable_optimized=no ; fi
if test -z "${enable_debug_symbols+set}"; then enable_debug_symbols=yes ; fi
+ if test -z "${enable_statistics+set}" ; then enable_statistics=yes ; fi
if test -z "${enable_assertions+set}" ; then enable_assertions=yes ; fi
if test -z "${enable_tracing+set}" ; then enable_tracing=yes ; fi
- if test -z "${enable_statistics+set}" ; then enable_statistics=yes ; fi
if test -z "${enable_muzzle+set}" ; then enable_muzzle=no ; fi
;;
default) # moderately optimized, assertions, tracing
@@ -233,8 +244,8 @@ case "$with_build" in
if test -z "${OPTLEVEL+set}" ; then OPTLEVEL=2 ; fi
if test -z "${enable_optimized+set}" ; then enable_optimized=yes ; fi
if test -z "${enable_debug_symbols+set}"; then enable_debug_symbols=yes ; fi
- if test -z "${enable_assertions+set}" ; then enable_assertions=yes ; fi
if test -z "${enable_statistics+set}" ; then enable_statistics=yes ; fi
+ if test -z "${enable_assertions+set}" ; then enable_assertions=yes ; fi
if test -z "${enable_tracing+set}" ; then enable_tracing=yes ; fi
if test -z "${enable_muzzle+set}" ; then enable_muzzle=no ; fi
;;
@@ -247,8 +258,8 @@ case "$with_build" in
if test -z "${OPTLEVEL+set}" ; then OPTLEVEL=9 ; fi
if test -z "${enable_optimized+set}" ; then enable_optimized=yes ; fi
if test -z "${enable_debug_symbols+set}"; then enable_debug_symbols=no ; fi
- if test -z "${enable_assertions+set}" ; then enable_assertions=no ; fi
if test -z "${enable_statistics+set}" ; then enable_statistics=no ; fi
+ if test -z "${enable_assertions+set}" ; then enable_assertions=no ; fi
if test -z "${enable_tracing+set}" ; then enable_tracing=no ; fi
if test -z "${enable_muzzle+set}" ; then enable_muzzle=yes ; fi
;;
@@ -625,17 +636,17 @@ Build profile: $with_build
Build ID : $build_type
Optimized : $optimized
Debug symbols: $enable_debug_symbols
+Statistics : $enable_statistics
Assertions : $enable_assertions
Tracing : $enable_tracing
Muzzle : $enable_muzzle
gcov support : $enable_coverage
gprof support: $enable_profiling
-unit tests : $support_unit_tests
-statistics : $enable_statistics
+Unit tests : $support_unit_tests
-static libs : $enable_static
-shared libs : $enable_shared
-static binary: $enable_static_binary
+Static libs : $enable_static
+Shared libs : $enable_shared
+Static binary: $enable_static_binary
CPPFLAGS : $CPPFLAGS
CXXFLAGS : $CXXFLAGS
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback