summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndres Notzli <andres.noetzli@gmail.com>2017-04-19 08:46:59 -0700
committerAndres Notzli <andres.noetzli@gmail.com>2017-04-21 01:24:09 -0700
commit2a26e0be7238cb055f0e121df050ea1e342a2fa2 (patch)
tree5e563fc869b178f5189950af57e468267a4d008d /configure.ac
parent8a0d2b0577e174d2078026129dd01ea46f7f984a (diff)
Add check for C++ exceptions to config script
Bug 687 was caused by the configuration not properly supporting C++ exceptions. To avoid such an incidence in the future, this commit adds a simple check to `configure.ac` (when not cross compiling).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d2c08661b..7da86d8a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -253,6 +253,27 @@ AC_PROG_INSTALL
CVC4_GCC_VERSION
+if test $cross_compiling = "no"; then
+ AC_MSG_CHECKING([whether C++ exceptions work])
+ AC_LANG_PUSH([C++])
+ AC_RUN_IFELSE(
+ AC_LANG_PROGRAM([#include <exception>], [[
+ int result = 1;
+ try {
+ throw std::exception();
+ } catch (...) {
+ result = 0;
+ }
+ return result;
+ ]]),
+ [AC_MSG_RESULT([yes])],
+ [AC_MSG_ERROR([C++ exceptions do not work.])]
+ )
+ AC_LANG_POP([C++])
+else
+ AC_MSG_WARN([Cross compiling, cannot check whether exceptions work])
+fi
+
cvc4_use_gmp=2
cvc4_use_cln=2
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback