summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-02-22 19:22:56 +0000
committerMorgan Deters <mdeters@gmail.com>2010-02-22 19:22:56 +0000
commitc96d62d41a178e0f524c39a0f73da9b7730dcf0b (patch)
tree593a1e9f62cc9605ac374df1203e85e437d424d9 /configure.ac
parent9ae657c4568114eb888d9c0b8c27c09586556ff3 (diff)
undoing improperly-committed revision 232; will re-commit to get "svn blame" correct, etc..
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac56
1 files changed, 18 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index 8c1141b9d..36f6d6c16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,7 @@
dnl Preprocess CL args. Defined in config/cvc4.m4
CVC4_AC_INIT
-AC_PREREQ(2.61)
+AC_PREREQ(2.64)
AC_INIT
AC_CONFIG_SRCDIR([src/include/cvc4_config.h])
AC_CONFIG_AUX_DIR([config])
@@ -30,7 +30,7 @@ CVC4_RELEASE_STRING=prerelease
#
# For more information, see:
# http://www.gnu.org/software/libtool/manual/libtool.html#Versioning
-# For guidance on when to change the version number, refer to the
+# For guidance on when to change the version number, refer to the
# developer's guide.
CVC4_LIBRARY_VERSION=$CVC4_MAJOR:$CVC4_MINOR:$CVC4_RELEASE
@@ -195,24 +195,10 @@ case "$with_build" in
;;
esac
-# permit a static binary
-AC_MSG_CHECKING([whether to build a static binary])
-AC_ARG_ENABLE([static-binary],
- [AS_HELP_STRING([--enable-static-binary],
- [build a statically-linked binary [default=no]])])
-if test -z "${enable_static_binary+set}"; then
- enable_static_binary=no
-fi
-AC_MSG_RESULT([$enable_static_binary])
-if test "${enable_static_binary}" = yes -a "${enable_static}" != yes; then
- enable_static=yes
- AC_MSG_WARN([forcing static-library building, --enable-static-binary given])
-fi
-
AC_MSG_CHECKING([whether to optimize libcvc4])
AC_ARG_ENABLE([optimized],
- [AS_HELP_STRING([--enable-optimized],
+ [AS_HELP_STRING([--enable-optimized],
[optimize the build])])
if test -z "${enable_optimized+set}"; then
@@ -227,8 +213,8 @@ fi
AC_MSG_CHECKING([whether to include debugging symbols in libcvc4])
-AC_ARG_ENABLE([debug-symbols],
- [AS_HELP_STRING([--disable-debug-symbols],
+AC_ARG_ENABLE([debug-symbols],
+ [AS_HELP_STRING([--disable-debug-symbols],
[do not include debug symbols in libcvc4])])
if test -z "${enable_debug_symbols+set}"; then
@@ -243,8 +229,8 @@ fi
AC_MSG_CHECKING([whether to include assertions in build])
-AC_ARG_ENABLE([assertions],
- [AS_HELP_STRING([--disable-assertions],
+AC_ARG_ENABLE([assertions],
+ [AS_HELP_STRING([--disable-assertions],
[turn off assertions in build])])
if test -z "${enable_assertions+set}"; then
@@ -258,8 +244,8 @@ if test "$enable_assertions" = yes; then
fi
AC_MSG_CHECKING([whether to do a traceable build of CVC4])
-AC_ARG_ENABLE([tracing],
- [AS_HELP_STRING([--disable-tracing],
+AC_ARG_ENABLE([tracing],
+ [AS_HELP_STRING([--disable-tracing],
[remove all tracing code from CVC4])])
if test -z "${enable_tracing+set}"; then
@@ -273,8 +259,8 @@ if test "$enable_tracing" = yes; then
fi
AC_MSG_CHECKING([whether to do a muzzled build of CVC4])
-AC_ARG_ENABLE([muzzle],
- [AS_HELP_STRING([--enable-muzzle],
+AC_ARG_ENABLE([muzzle],
+ [AS_HELP_STRING([--enable-muzzle],
[completely silence CVC4; remove ALL non-result output from build])])
if test -z "${enable_muzzle+set}"; then
@@ -288,8 +274,8 @@ if test "$enable_muzzle" = yes; then
fi
AC_MSG_CHECKING([whether to do a gcov-enabled build of CVC4])
-AC_ARG_ENABLE([coverage],
- [AS_HELP_STRING([--enable-coverage],
+AC_ARG_ENABLE([coverage],
+ [AS_HELP_STRING([--enable-coverage],
[build with support for gcov coverage testing])])
if test -z "${enable_coverage+set}"; then
@@ -305,8 +291,8 @@ fi
AC_MSG_CHECKING([whether to do a profiling-enabled build of CVC4])
-AC_ARG_ENABLE([profiling],
- [AS_HELP_STRING([--enable-profiling],
+AC_ARG_ENABLE([profiling],
+ [AS_HELP_STRING([--enable-profiling],
[build with support for gprof profiling])])
if test -z "${enable_profiling+set}"; then
@@ -339,11 +325,9 @@ DX_PS_FEATURE(OFF)
DX_DOT_FEATURE(OFF)
DX_INIT_DOXYGEN($PACKAGE_NAME, config/doxygen.cfg, $srcdir/doc)
-AC_ARG_VAR(CXXTEST, [path to CxxTest installation])
-
AC_SUBST([CXXTEST])
-AC_ARG_WITH([cxxtest-dir],
+AC_ARG_WITH([cxxtest-dir],
[AS_HELP_STRING([--with-cxxtest-dir=DIR], [path to CxxTest installation])],
[CXXTEST="$withval"])
@@ -405,7 +389,7 @@ AC_LIB_ANTLR
AC_CHECK_HEADERS([getopt.h unistd.h])
# Checks for typedefs, structures, and compiler characteristics.
-#AC_HEADER_STDBOOL
+AC_HEADER_STDBOOL
AC_TYPE_UINT16_T
AC_TYPE_UINT32_T
AC_TYPE_UINT64_T
@@ -423,7 +407,7 @@ if test "$enable_shared" = yes; then BUILDING_SHARED=1; fi
if test "$enable_static" = yes; then BUILDING_STATIC=1; fi
AC_SUBST(BUILDING_SHARED)
AC_SUBST(BUILDING_STATIC)
-AM_CONDITIONAL([STATIC_BINARY], [test "$enable_static_binary" = yes])
+AM_CONDITIONAL([STATIC_BINARY], [test "$enable_shared" != yes -a "$enable_static" = yes])
AC_SUBST(CVC4_LIBRARY_VERSION)
AC_SUBST(CVC4_PARSER_LIBRARY_VERSION)
@@ -494,10 +478,6 @@ gcov support : $enable_coverage
gprof support: $enable_profiling
unit tests : $support_unit_tests
-static libs : $enable_static
-shared libs : $enable_shared
-static binary: $enable_static_binary
-
CPPFLAGS : $CPPFLAGS
CXXFLAGS : $CXXFLAGS
LDFLAGS : $LDFLAGS
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback