summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-02-22 20:36:15 +0000
committerMorgan Deters <mdeters@gmail.com>2012-02-22 20:36:15 +0000
commit2ef6c6a2a9dcf4f86bda32ceba0975f9f2a2e8ed (patch)
tree6c2763ef098f2992faef81af597783ce2f65728d /configure.ac
parente1d2304f93adc9bd53d0d715de02648c2ba369fa (diff)
another static library unavailability issue
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d44dc3620..91af13e72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -862,6 +862,10 @@ AC_ARG_WITH([portfolio],
AS_HELP_STRING([--with-portfolio], [build the multithreaded portfolio version of CVC4 (pcvc4)]),
[if test "$withval" = no; then cvc4_has_threads=no; elif test "$withval" = yes; then cvc4_must_have_threads=yes; fi])
if test $cvc4_has_threads = maybe; then
+ cvc4_save_LDFLAGS="$LDFLAGS"
+ if test "$enable_static_binary" = yes; then
+ LDFLAGS="-static $LDFLAGS"
+ fi
BOOST_REQUIRE([], [cvc4_has_threads=no])
if test $cvc4_has_threads = no; then
AC_MSG_WARN([disabling multithreaded support])
@@ -874,6 +878,7 @@ if test $cvc4_has_threads = maybe; then
cvc4_has_threads=no
fi
fi
+ LDFLAGS="$cvc4_save_LDFLAGS"
fi
if test $cvc4_has_threads = no -a $cvc4_must_have_threads = yes; then
AC_MSG_ERROR([user gave --with-portfolio but could not build with threads; maybe boost threading library is missing?])
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback