summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristopher L. Conway <christopherleeconway@gmail.com>2009-12-16 17:52:49 +0000
committerChristopher L. Conway <christopherleeconway@gmail.com>2009-12-16 17:52:49 +0000
commite5d54c5ba02645ce6dacf626aa32dfd5495a8bc9 (patch)
treedea8ac344a1b7e5d74ae60ae0836765a3601443f /configure.ac
parent79df573326e6911d3a97fcc2528105acd1c2c525 (diff)
Standardizing configure arguments for ANTLR/CxxTest
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8b4a3ea64..524f015d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -269,7 +269,12 @@ if test -z "$DOXYGEN"; then
fi
AC_ARG_VAR(DOXYGEN, [location of doxygen binary])
-AC_ARG_VAR(CXXTEST, [path to cxxtest installation])
+AC_SUBST([CXXTEST])
+AC_ARG_WITH([cxxtest-dir],
+ [AS_HELP_STRING([--with-cxxtest-dir=DIR], [path to CxxTest installation])],
+ [CXXTEST="$withval"])
+
+dnl AC_ARG_VAR(CXXTEST, [path to cxxtest installation])
CXXTESTGEN=
AC_PATH_PROG(CXXTESTGEN, cxxtestgen.pl, [], [$CXXTEST:$PATH])
if test -z "$CXXTESTGEN"; then
@@ -286,7 +291,6 @@ elif test -z "$CXXTEST"; then
CXXTEST=
fi
fi
-AC_ARG_WITH([cxxtest], [AS_HELP_STRING([--with-cxxtest=dir], [path to CxxTest installation])])
AM_CONDITIONAL([HAVE_CXXTESTGEN], [test -n "$CXXTESTGEN"])
AC_ARG_VAR(TEST_CPPFLAGS, [CXXFLAGS to use when testing (default=$CPPFLAGS)])
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback