summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2009-11-19 22:07:01 +0000
committerMorgan Deters <mdeters@gmail.com>2009-11-19 22:07:01 +0000
commitcd98370b338a0cc5343067151884a06431a1d92c (patch)
tree7e61d8cf61ada9fef8f470a3c781a07a5df5a0fc /configure.ac
parent394791604a62e19763a8a45328bc5177d91fabf9 (diff)
testing framework, configure fixes, incorporations from meeting, continued work
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 77c03ef2c..57dde9b35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,30 @@ AC_CHECK_PROG(DOXYGEN, doxygen, doxygen, [])
if test -z "$DOXYGEN"; then
AC_MSG_WARN([documentation targets require doxygen. Set your PATH appropriately or set DOXYGEN to point to a valid doxygen binary.])
fi
+AC_ARG_VAR(DOXYGEN, [location of doxygen binary])
+
+CXXTESTGEN=
+AC_PATH_PROG(CXXTESTGEN, cxxtestgen.pl, [], [$CXXTEST:$PATH])
+if test -z "$CXXTESTGEN"; then
+ AC_MSG_NOTICE([unit tests disabled, cxxtestgen.pl not found.])
+elif test -z "$CXXTEST"; then
+ CXXTEST=$(dirname "$CXXTESTGEN")
+ AC_MSG_CHECKING([for location of CxxTest headers])
+ if test -e "$CXXTEST/cxxtest/TestRunner.h"; then
+ AC_MSG_RESULT([$CXXTEST])
+ else
+ AC_MSG_RESULT([not found])
+ AC_MSG_WARN([unit tests disabled, CxxTest headers not found.])
+ CXXTESTGEN=
+ CXXTEST=
+ fi
+fi
+AC_ARG_VAR(CXXTEST, [path to CxxTest installation])
+AM_CONDITIONAL([HAVE_CXXTESTGEN], [test -n "$CXXTESTGEN"])
+
+AC_ARG_VAR(TEST_CPPFLAGS, [CXXFLAGS to use when testing (default=$CPPFLAGS)])
+AC_ARG_VAR(TEST_CXXFLAGS, [CXXFLAGS to use when testing (default=$CXXFLAGS)])
+AC_ARG_VAR(TEST_LDFLAGS, [LDFLAGS to use when testing (default=$LDFLAGS)])
# Checks for libraries.
AC_CHECK_LIB(gmp, __gmpz_init, , [AC_MSG_ERROR([GNU MP not found, see http://gmplib.org/])])
@@ -84,6 +108,7 @@ AC_CONFIG_FILES([
src/context/Makefile
src/parser/Makefile
src/theory/Makefile
+ test/Makefile
])
AC_OUTPUT
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback