summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLiana Hadarean <lianahady@gmail.com>2011-10-28 19:24:38 +0000
committerLiana Hadarean <lianahady@gmail.com>2011-10-28 19:24:38 +0000
commitb084a7efa9d65ec2f7475caa8486f8fd4cbafbd5 (patch)
treee118097c88787b7f2899bb8b2cbf865d058ef6bf /configure.ac
parent9547a48a7cdab8786c080779930de9c39655c52b (diff)
merged the proofgen3 branch into trunk:
- can now output LFSC checkable resolution proofs - added configuration option --enable-proof - added command line argument --proof To turn proofs on build with proofs enabled and run with --proof.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cabb50706..922f65416 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,6 +145,13 @@ if test -n "${enable_assertions+set}"; then
btargs="$btargs noassertions"
fi
fi
+if test -n "${enable_proof+set}"; then
+ if test "$enable_proof" = yes; then
+ btargs="$btargs proof"
+ else
+ btargs="$btargs noproof"
+ fi
+fi
if test -n "${enable_tracing+set}"; then
if test "$enable_tracing" = yes; then
btargs="$btargs tracing"
@@ -374,6 +381,7 @@ case "$with_build" in
if test -z "${enable_statistics+set}" ; then enable_statistics=yes ; fi
if test -z "${enable_replay+set}" ; then enable_replay=no ; fi
if test -z "${enable_assertions+set}" ; then enable_assertions=no ; fi
+ if test -z "${enable_proof+set}" ; then enable_proof=no ; fi
if test -z "${enable_tracing+set}" ; then enable_tracing=no ; fi
if test -z "${enable_dumping+set}" ; then enable_dumping=yes ; fi
if test -z "${enable_muzzle+set}" ; then enable_muzzle=no ; fi
@@ -389,6 +397,7 @@ case "$with_build" in
if test -z "${enable_statistics+set}" ; then enable_statistics=yes ; fi
if test -z "${enable_replay+set}" ; then enable_replay=yes ; fi
if test -z "${enable_assertions+set}" ; then enable_assertions=yes ; fi
+ if test -z "${enable_proof+set}" ; then enable_proof=no ; fi
if test -z "${enable_tracing+set}" ; then enable_tracing=yes ; fi
if test -z "${enable_dumping+set}" ; then enable_dumping=yes ; fi
if test -z "${enable_muzzle+set}" ; then enable_muzzle=no ; fi
@@ -405,6 +414,7 @@ case "$with_build" in
if test -z "${enable_statistics+set}" ; then enable_statistics=yes ; fi
if test -z "${enable_replay+set}" ; then enable_replay=yes ; fi
if test -z "${enable_assertions+set}" ; then enable_assertions=yes ; fi
+ if test -z "${enable_proof+set}" ; then enable_proof=no ; fi
if test -z "${enable_tracing+set}" ; then enable_tracing=yes ; fi
if test -z "${enable_dumping+set}" ; then enable_dumping=yes ; fi
if test -z "${enable_muzzle+set}" ; then enable_muzzle=no ; fi
@@ -421,6 +431,7 @@ case "$with_build" in
if test -z "${enable_statistics+set}" ; then enable_statistics=no ; fi
if test -z "${enable_replay+set}" ; then enable_replay=no ; fi
if test -z "${enable_assertions+set}" ; then enable_assertions=no ; fi
+ if test -z "${enable_proof+set}" ; then enable_proof=no ; fi
if test -z "${enable_tracing+set}" ; then enable_tracing=no ; fi
if test -z "${enable_dumping+set}" ; then enable_dumping=no ; fi
if test -z "${enable_muzzle+set}" ; then enable_muzzle=yes ; fi
@@ -453,6 +464,21 @@ if test "$enable_static_binary" = yes -a "$enable_static" != yes; then
AC_MSG_WARN([forcing static-library building, --enable-static-binary given])
fi
+AC_MSG_CHECKING([whether to support proof in libcvc4])
+
+AC_ARG_ENABLE([proof],
+ [AS_HELP_STRING([--enable-proof],
+ [support proof generation])])
+if test -z "${enable_proof+set}"; then
+ enable_proof=no
+fi
+AC_MSG_RESULT([$enable_proof])
+
+if test "$enable_proof" = yes; then
+ CVC4CPPFLAGS="${CVC4CPPFLAGS:+$CVC4CPPFLAGS }-DCVC4_PROOF"
+fi
+
+
AC_MSG_CHECKING([whether to optimize libcvc4])
AC_ARG_ENABLE([optimized],
@@ -1026,6 +1052,7 @@ Build profile: $with_build
Build ID : $build_type
Optimized : $optimized
Debug symbols: $enable_debug_symbols
+Proof : $enable_proof
Statistics : $enable_statistics
Replay : $enable_replay
Assertions : $enable_assertions
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback