summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2017-08-25 15:39:16 -0700
committerGitHub <noreply@github.com>2017-08-25 15:39:16 -0700
commitdfa69ff98a14fcc0f2387e59a0c9994ef440e7d0 (patch)
tree23031231926757cb9b8aab425d8354683a3a66d7 /configure.ac
parent378a0c45070ec033493c52e4fa92e6d03b89b6c0 (diff)
Move LFSC checker out of the CVC repository. (#222)
LFSC now lives outside of the CVC4 repository and is not part of the CVC4 distribution anymore. As a consequence, we + Add --with-lfsc and --with-lfsc-directory as configure options. In the case where CVC4 has not been built with integrated LFSC, all code that interacts with LFSC is disabled. + Disable proof checking if CVC4_USE_LFSC is not defined. Configuring the build with --check-proofs but without --with-lfsc results in an error. + Do not call LFSC's cleanup function (but we should in the future). LFSC checker segfaults during cleanup on regression testcase regress0/bv/core/bitvec7.smt. Disabled call to lfscc_cleanup until the problem in lfscc is fixed. + Disable building with LFSC for the distcheck travis build since it is not part of the distribution anymore. Further, make distcheck with LFSC would require to call contrib/get-lfsc-checker before calling make check on the temp build (the build of the unpacked distribution tar ball).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 36 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 55bd91c9d..1c0240f36 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,6 @@ AC_CONFIG_SRCDIR([src/include/cvc4_public.h])
AC_CONFIG_AUX_DIR([config])
AC_CONFIG_MACRO_DIR([config])
AC_CONFIG_LIBOBJ_DIR([src/lib])
-AC_CONFIG_SUBDIRS([proofs/lfsc_checker])
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
@@ -117,7 +116,22 @@ AC_ARG_WITH([build],
if test -z "${with_build+set}"; then
with_build=production
fi
-if test -z "${enable_optimized+set}" -a -z "${enable_debug_symbols+set}" -a -z "${enable_assertions+set}" -a -z "${enable_tracing+set}" -a -z "${enable_dumping+set}" -a -z "${enable_muzzle+set}" -a -z "${enable_coverage+set}" -a -z "${enable_profiling+set}" -a -z "${enable_statistics+set}" -a -z "${enable_replay+set}" -a -z "${with_gmp+set}" -a -z "${with_cln+set}" -a -z "${with_glpk+set}" -a -z "${with_abc+set}" -a -z "${with_cryptominisat+set}"; then
+if test -z "${enable_optimized+set}" -a \
+ -z "${enable_debug_symbols+set}" -a \
+ -z "${enable_assertions+set}" -a \
+ -z "${enable_tracing+set}" -a \
+ -z "${enable_dumping+set}" -a \
+ -z "${enable_muzzle+set}" -a \
+ -z "${enable_coverage+set}" -a \
+ -z "${enable_profiling+set}" -a \
+ -z "${enable_statistics+set}" -a \
+ -z "${enable_replay+set}" -a \
+ -z "${with_gmp+set}" -a \
+ -z "${with_cln+set}" -a \
+ -z "${with_glpk+set}" -a \
+ -z "${with_abc+set}" -a \
+ -z "${with_cryptominisat+set}" -a \
+ -z "${with_lfsc+set}"; then
custom_build_profile=no
else
custom_build_profile=yes
@@ -226,6 +240,12 @@ if test -n "${with_cryptominisat+set}"; then
btargs="$btargs cryptominisat"
fi
fi
+if test -n "${with_lfsc+set}"; then
+ if test "$with_lfsc" = yes; then
+ enable_proof=yes
+ btargs="$btargs lfsc"
+ fi
+fi
AC_MSG_RESULT([$with_build])
@@ -828,6 +848,18 @@ AM_CONDITIONAL([CVC4_USE_CRYPTOMINISAT], [test $have_libcryptominisat -eq 1])
AC_SUBST([CRYPTOMINISAT_LDFLAGS])
AC_SUBST([CRYPTOMINISAT_LIBS])
+# Build with LFSC
+AC_ARG_WITH([lfsc],
+ [AS_HELP_STRING([--with-lfsc],
+ [use the LFSC proof checker])], [], [with_lfsc=])
+CVC4_CHECK_FOR_LFSC
+if test $have_liblfsc -eq 1; then
+ CVC4CPPFLAGS="${CVC4CPPFLAGS:+$CVC4CPPFLAGS }-DCVC4_USE_LFSC"
+fi
+AM_CONDITIONAL([CVC4_USE_LFSC], [test $have_liblfsc -eq 1])
+AC_SUBST([LFSC_LDFLAGS])
+AC_SUBST([LFSC_LIBS])
+
# Check to see if this version/architecture of GNU C++ explicitly
# instantiates std::hash<uint64_t> or not. Some do, some don't.
@@ -935,7 +967,8 @@ AC_ARG_WITH([cxxtest-dir],
TESTS_ENVIRONMENT=
RUN_REGRESSION_ARGS=
-if test "$enable_proof" = yes; then
+# FIXME currently, unsat core regressions are disabled without LFSC
+if test "$with_lfsc" = yes; then
RUN_REGRESSION_ARGS="${RUN_REGRESSION_ARGS:+$RUN_REGRESSION_ARGS }--proof"
fi
AC_SUBST([TESTS_ENVIRONMENT])
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback