summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndres Noetzli <andres.noetzli@gmail.com>2017-07-17 08:07:59 -0400
committerGitHub <noreply@github.com>2017-07-17 08:07:59 -0400
commit53a226a753e509e028c386072c87d94c0a1316be (patch)
treec9e99087d040e7e79fa319c80d15f9450fbb75d0 /configure.ac
parentefac53e969ccefc01bace1a5f095dfd3570c3767 (diff)
Use is_sorted, merge, copy from std (#199)
Previously, we were checking whether we should use is_sorted from std or __gnu_cxx. With C++11, std::is_sorted is guaranteed to exist. This commit changes arith/normal_form.{h,cpp} to always use std::is_sorted and also removes the custom implementations for merge and copy by using the std implementations instead.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b321fef6b..c0cec382f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1073,9 +1073,6 @@ AC_CHECK_DECLS([optreset], [], [], [#include <getopt.h>])
# check with which standard strerror_r() complies
AC_FUNC_STRERROR_R
-# is is_sorted() in std or __gnu_cxx?
-CHECK_FOR_IS_SORTED
-
# require boost library
BOOST_REQUIRE()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback