summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@cs.nyu.edu>2013-12-18 12:23:24 -0500
committerMorgan Deters <mdeters@cs.nyu.edu>2013-12-18 14:27:29 -0500
commit28d95f84b62d2c00b475d0204bfac7d77d679586 (patch)
treead33fd3c6618f9248e920fa641ea04457e44fc45 /configure.ac
parentb605831878a2be688379f593ce39d37a3d7e18a3 (diff)
Fix an autoconf issue with CLN in some configurations; also clarification re: license issues
[skip ci]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a9177fbc5..6e51951f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -298,6 +298,8 @@ if test $cvc4_use_cln != 0; then
# we have to have PKG_CHECK_MODULES _exactly_ once in configure.ac !
PKG_CHECK_MODULES([CLN], [cln >= 1.2.2],
[AC_LANG_PUSH([C++])
+ save_LIBS="$LIBS"
+ LIBS="$CLN_LIBS $LIBS"
AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <cln/cln.h>]], [[cln::cl_F pi = "3.1415926";]])], [
cvc4_use_cln=1
], [
@@ -311,6 +313,7 @@ if test $cvc4_use_cln != 0; then
cvc4_use_gmp=1
fi
])
+ LIBS="$save_LIBS"
AC_LANG_POP([C++])
],
[if test $cvc4_use_cln = 1; then
@@ -1357,7 +1360,7 @@ Please note that CVC4 will be built against the following GPLed libraries:
As these libraries are covered under the GPLv3, so is this build of CVC4.
CVC4 is also available to you under the terms of the (modified) BSD license.
If you prefer to license CVC4 under those terms, please configure with the
-option "--bsd".
+option "--bsd", which will disable all optional GPLed library dependences.
****************************************************************************
'
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback