summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndres Noetzli <andres.noetzli@gmail.com>2017-07-26 17:05:12 -0700
committerGitHub <noreply@github.com>2017-07-26 17:05:12 -0700
commit661edc4948b72a615b04bf0d4cfa41018f29f6be (patch)
tree734395d978d3fa97eb4ec8864eeb3718237ff763 /configure.ac
parenta354816a5d6b9026383e9982f3cf25996eddd3ba (diff)
-Og for non-opt build, parallel pcvc4 check (#206)
-Og enables optimizations that do not interfere with debugging. This is the new default for debug builds if the compiler supports the flag. This commit also enables parallel checking for the portfolio build on Travis.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b32bbc9b1..30098305f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -600,8 +600,12 @@ if test "$enable_optimized" = yes; then
CVC4CXXFLAGS="${CVC4CXXFLAGS:+$CVC4CXXFLAGS }-O$OPTLEVEL"
CVC4CFLAGS="${CVC4CFLAGS:+$CVC4CFLAGS }-O$OPTLEVEL"
else
- CVC4CXXFLAGS="${CVC4CXXFLAGS:+$CVC4CXXFLAGS }-O0"
- CVC4CFLAGS="${CVC4CFLAGS:+$CVC4CFLAGS }-O0"
+ # Use -Og if available (optimizations that do not interfere with debugging),
+ # -O0 otherwise
+ debug_optimization_level="-O0"
+ CVC4_CXX_OPTION([-Og], [debug_optimization_level])
+ CVC4CXXFLAGS="${CVC4CXXFLAGS:+$CVC4CXXFLAGS }${debug_optimization_level}"
+ CVC4CFLAGS="${CVC4CFLAGS:+$CVC4CFLAGS }${debug_optimization_level}"
fi
AC_MSG_CHECKING([whether to include debugging symbols in libcvc4])
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback