summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-07-27 12:50:47 -0700
committerAndres Noetzli <andres.noetzli@gmail.com>2018-07-27 12:50:47 -0700
commit1832d76aaacd9b19e4b6bdb0549579a6eda5b1a4 (patch)
treec7e386cedf4e8b56059d32c5885200610563b1b4 /configure.ac
parent6a2abb85c96f973247a875229e84d91643894345 (diff)
Make Python a required CVC4 dependency. (#2227)
Python is required for generating the options code. The dependency is now required. Now autoconf searches for a Python version >= 2.7 and sets the corresponding environment variables. mkoptions.py is now called with $(PYTHON). This fixes the broken competition and windows nightly builds.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 4 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 9ec9923c0..1480879c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1142,19 +1142,10 @@ AM_CONDITIONAL([HAVE_CXXTESTGEN], [test -n "$CXXTESTGEN"])
AC_ARG_VAR(PERL, [PERL interpreter (used when testing)])
-AC_ARG_VAR(PYTHON, [PYTHON interpreter (used for building legacy Java library interface)])
-
-if test -z "$PYTHON"; then
- AC_CHECK_PROGS(PYTHON, python, python, [])
-else
- AC_CHECK_PROG(PYTHON, "$PYTHON", "$PYTHON", [])
-fi
-
-if test -z "$PYTHON"; then
- AC_MSG_WARN([python not found, cannot build libcvc4compat_java (the legacy Java interface).])
- CXXTESTGEN=
- CXXTEST=
-fi
+# Python is now a required dependency for generating options code
+AM_PATH_PYTHON([2.7],, [
+ AC_MSG_ERROR([Python not found.])
+])
# Checks for libraries.
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback