summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@cs.nyu.edu>2014-06-21 17:28:01 -0400
committerMorgan Deters <mdeters@cs.nyu.edu>2014-06-21 19:13:05 -0400
commitfaa803ebfae243cf4739a3f2249c3f57b0e56a19 (patch)
tree8469c77b57c4685caf130cf13a87e008d2ea4054 /configure.ac
parent32c2090301d549efcb8a6ad7034b0553ed99b433 (diff)
Adjust library dependencies to be more correct (fixes lintian warnings).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 31dec369b..487ec7e38 100644
--- a/configure.ac
+++ b/configure.ac
@@ -335,8 +335,10 @@ if test $cvc4_use_cln != 0; then
)
fi
if test $cvc4_use_cln = 0; then
- # try GMPXX, fail if not found
- AC_CHECK_LIB(gmpxx, __gmpz_init, , [AC_MSG_ERROR([GNU MP C++ library (libgmpxx) not found, see http://gmplib.org/])])
+ # try GMPXX, fail if not found; don't need to link against it, only need its header
+ AC_LANG_PUSH([C++])
+ AC_CHECK_HEADER([gmpxx.h], , [AC_MSG_ERROR([GNU MP C++ library header (gmpxx.h) required but not found, see http://gmplib.org/])])
+ AC_LANG_POP([C++])
cvc4_cln_or_gmp=gmp
else
CVC4CPPFLAGS="${CVC4CPPFLAGS:+$CVC4CPPFLAGS }$CLN_CFLAGS"
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback