summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-02-22 01:10:58 +0000
committerMorgan Deters <mdeters@gmail.com>2010-02-22 01:10:58 +0000
commit65fa7fd4d674e00624657255c24748e580ef50d6 (patch)
tree1a5591fca4c3a9ab24d576c282f36607cb81a7f5 /configure.ac
parent7697b5218118d71800318472a7423a5b42bee469 (diff)
fix bug 22 (remove tracing from non-trace builds; remove all output
from muzzled builds) add public-facing CVC4::Configuration class that gives CVC4's (static) configuration (whether debugging is enabled, assertions, version information, etc...) add some whitebox tests for assertions, output classes, and new CVC4::Configuration class main driver now gets about() information from CVC4::Configuration. configure.ac now more flexible at specifying major/minor/release versions of CVC4 add --show-config option that dumps CVC4's static configuration commented option processing strings in src/main/getopt.cpp fixed some compilation problems for muzzled builds. fixed some test code for non-assertion builds (where no assertions are expected)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6ee45bbb9..c67da8ba2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,7 +10,10 @@ AC_CONFIG_SRCDIR([src/include/cvc4_config.h])
AC_CONFIG_AUX_DIR([config])
AC_CONFIG_MACRO_DIR([config])
-CVC4_RELEASE=prerelease
+CVC4_MAJOR=0
+CVC4_MINOR=0
+CVC4_RELEASE=0
+CVC4_RELEASE_STRING=prerelease
# Libtool version numbers for libraries
# Version numbers are in the form current:revision:age
@@ -30,8 +33,8 @@ CVC4_RELEASE=prerelease
# For guidance on when to change the version number, refer to the
# developer's guide.
-CVC4_LIBRARY_VERSION=0:0:0
-CVC4_PARSER_LIBRARY_VERSION=0:0:0
+CVC4_LIBRARY_VERSION=$CVC4_MAJOR:$CVC4_MINOR:$CVC4_RELEASE
+CVC4_PARSER_LIBRARY_VERSION=$CVC4_MAJOR:$CVC4_MINOR:$CVC4_RELEASE
# Using the AC_CANONICAL_* macros destroy the command line you get
# from $@, which we want later for determining the build profile. So
@@ -303,7 +306,7 @@ if test "$enable_profiling" = yes; then
CVC4LDFLAGS="$CVC4LDFLAGS -pg"
fi
-AM_INIT_AUTOMAKE(cvc4, $CVC4_RELEASE)
+AM_INIT_AUTOMAKE(cvc4, $CVC4_RELEASE_STRING)
AC_CONFIG_HEADERS([config.h])
# Initialize libtool's configuration options.
@@ -408,6 +411,11 @@ AC_SUBST(BUILDING_STATIC)
AC_SUBST(CVC4_LIBRARY_VERSION)
AC_SUBST(CVC4_PARSER_LIBRARY_VERSION)
+AC_DEFINE_UNQUOTED(CVC4_MAJOR, ${CVC4_MAJOR}, [Major component of the version of CVC4.])
+AC_DEFINE_UNQUOTED(CVC4_MINOR, ${CVC4_MINOR}, [Minor component of the version of CVC4.])
+AC_DEFINE_UNQUOTED(CVC4_RELEASE, ${CVC4_RELEASE}, [Release component of the version of CVC4.])
+AC_DEFINE_UNQUOTED(CVC4_RELEASE_STRING, ["${CVC4_RELEASE_STRING}"], [Full release string for CVC4.])
+
CPPFLAGS="${CPPFLAGS:+$CPPFLAGS }$CVC4CPPFLAGS"
CXXFLAGS="${CXXFLAGS:+$CXXFLAGS }$CVC4CXXFLAGS -Wno-deprecated"
LDFLAGS="${LDFLAGS:+$LDFLAGS }$CVC4LDFLAGS"
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback