summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@cs.nyu.edu>2013-12-18 11:47:59 -0500
committerMorgan Deters <mdeters@cs.nyu.edu>2013-12-18 11:47:59 -0500
commit5fa40f4898d61c23e6d2d47a2963886898ecc939 (patch)
treefc90a6686e9d368cab4dd26483495700b370b72f /configure.ac
parentc174f4f68f656c320906bc1e18154bc4830e7965 (diff)
parentb605831878a2be688379f593ce39d37a3d7e18a3 (diff)
Merge branch '1.3.x'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 16 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b68b00746..ea4e397c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -298,9 +298,20 @@ if test $cvc4_use_cln != 0; then
# PKG_CHECK_MODULES([CLN], ...). That's why things are so convoluted here,
# we have to have PKG_CHECK_MODULES _exactly_ once in configure.ac !
PKG_CHECK_MODULES([CLN], [cln >= 1.2.2],
- [cvc4_use_cln=1
- AC_LANG_PUSH([C++])
- AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <cln/cln.h>]], [[cln::cl_F pi = "3.1415926";]])])
+ [AC_LANG_PUSH([C++])
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <cln/cln.h>]], [[cln::cl_F pi = "3.1415926";]])], [
+ cvc4_use_cln=1
+ ], [
+ if test $cvc4_use_cln = 1; then
+ # fail
+ AC_MSG_ERROR([CLN installation missing, too old, or not functional for this architecture])
+ else
+ # fall back to GMP
+ AC_MSG_NOTICE([CLN installation missing, too old, or not functional for this architecture, will use gmp instead])
+ cvc4_use_cln=0
+ cvc4_use_gmp=1
+ fi
+ ])
AC_LANG_POP([C++])
],
[if test $cvc4_use_cln = 1; then
@@ -309,6 +320,8 @@ if test $cvc4_use_cln != 0; then
else
# fall back to GMP
AC_MSG_NOTICE([CLN not installed (or too old) or pkgconfig missing, will use gmp])
+ cvc4_use_cln=0
+ cvc4_use_gmp=1
fi
]
)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback