summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@cs.nyu.edu>2013-12-18 14:27:55 -0500
committerMorgan Deters <mdeters@cs.nyu.edu>2013-12-18 14:27:55 -0500
commitc33d53d005c41cf5705a85f86311d8d0142d2a01 (patch)
treebf57bd57e84b71122c4a748d228125126a3f40fd /configure.ac
parent5fa40f4898d61c23e6d2d47a2963886898ecc939 (diff)
parent28d95f84b62d2c00b475d0204bfac7d77d679586 (diff)
Merge branch '1.3.x'
[skip ci]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ea4e397c1..38f5681fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -299,6 +299,8 @@ if test $cvc4_use_cln != 0; then
# we have to have PKG_CHECK_MODULES _exactly_ once in configure.ac !
PKG_CHECK_MODULES([CLN], [cln >= 1.2.2],
[AC_LANG_PUSH([C++])
+ save_LIBS="$LIBS"
+ LIBS="$CLN_LIBS $LIBS"
AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <cln/cln.h>]], [[cln::cl_F pi = "3.1415926";]])], [
cvc4_use_cln=1
], [
@@ -312,6 +314,7 @@ if test $cvc4_use_cln != 0; then
cvc4_use_gmp=1
fi
])
+ LIBS="$save_LIBS"
AC_LANG_POP([C++])
],
[if test $cvc4_use_cln = 1; then
@@ -1359,7 +1362,7 @@ Please note that CVC4 will be built against the following GPLed libraries:
As these libraries are covered under the GPLv3, so is this build of CVC4.
CVC4 is also available to you under the terms of the (modified) BSD license.
If you prefer to license CVC4 under those terms, please configure with the
-option "--bsd".
+option "--bsd", which will disable all optional GPLed library dependences.
****************************************************************************
'
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback