summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@cs.nyu.edu>2013-09-05 09:14:39 -0400
committerMorgan Deters <mdeters@cs.nyu.edu>2013-09-18 17:15:25 -0400
commit54977fe59a1dd28a20f7c01d10523f966fd67213 (patch)
tree508209ca34c7d7a2fcf35c2c0430c84334f2764b /configure.ac
parentaa16fb32ac7a66e327f32ea4c794a3ccf832c587 (diff)
Support a personal build configuration and make rules.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 25 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dce990c69..56f462b34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,6 +69,7 @@ CVC4_BINDINGS_LIBRARY_VERSION=_CVC4_BINDINGS_LIBRARY_VERSION
# included in the output... autoconf overrides us on the orderings of
# some things.)
config_cmdline=("$@")
+cvc4_config_cmdline="${config_cmdline[[@]]}"
# remember if the user set these explicitly (or whether autoconf does)
user_specified_enable_or_disable_static=${enable_static+yes}
@@ -106,7 +107,7 @@ fi
AC_MSG_CHECKING([for requested build profile])
AC_ARG_WITH([build],
[AS_HELP_STRING([--with-build=profile],
- [for profile in {production,debug,default,competition}])])
+ [for profile in {production,debug,default,competition,personal}])])
if test -z "${with_build+set}" -o "$with_build" = default; then
with_build=default
@@ -812,6 +813,21 @@ if test "$target_vendor" = apple; then
CVC4CPPFLAGS="${CVC4CPPFLAGS:+$CVC4CPPFLAGS }-D_GLIBCXX_VISIBILITY_DEFAULT=\"__attribute__((__visibility__(\\\"default\\\")))\""
fi
+# Tell top-level Makefile to include $(top_srcdir)/personal.mk
+AC_ARG_ENABLE([personal-make-rules],
+ [AS_HELP_STRING([--enable-personal-make-rules],
+ [include top-level personal.mk (if it exists)])])
+if test "$enable_personal_make_rules" = yes; then
+ # This allows us to include a personal.mk makefile from every
+ # generated makefile. Named zz_* in order to make sure this
+ # comes last, so it gets other definitions (in particular top_srcdir).
+ zz_cvc4_use_personal_make_rules='yes
+
+include $(top_srcdir)/personal.mk
+$(top_srcdir)/personal.mk:; @touch "$@"'
+ AC_SUBST([zz_cvc4_use_personal_make_rules])
+fi
+
# Doxygen configuration
AC_ARG_ENABLE([internals-documentation],
[AS_HELP_STRING([--enable-internals-documentation],
@@ -1196,6 +1212,9 @@ AC_SUBST(FLAG_VISIBILITY_HIDDEN)
AC_SUBST(cvc4_LDFLAGS)
AC_SUBST(pcvc4_LDFLAGS)
+# remember the command line used for configure
+AC_SUBST(cvc4_config_cmdline)
+
# mk_include
#
# When automake scans Makefiles, it complains about non-standard make
@@ -1211,6 +1230,11 @@ AC_SUBST(pcvc4_LDFLAGS)
# makefiles with GNU extensions; this hides them from automake.
mk_include=include
AC_SUBST(mk_include)
+# Similar trickery for "if"
+mk_if=if
+AC_SUBST(mk_if)
+mk_empty=
+AC_SUBST(mk_empty)
# CVC4_FALSE
#
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback