summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDejan Jovanović <dejan.jovanovic@gmail.com>2009-12-06 02:21:46 +0000
committerDejan Jovanović <dejan.jovanovic@gmail.com>2009-12-06 02:21:46 +0000
commitc16be5841e613818d5764e4de99e4694a0703685 (patch)
tree5bf7c07a8f7200c2830d50f5dd83ecbb4f02444d /configure.ac
parent200f36785acf7aac3e7e230795ea7ffdb6b1ed64 (diff)
Big chunk of changes:
* Fixed bugs in option parsing * Simplified the main.cpp significantly (more c++ like) * Added the null kind, expr value, and expression, with the default constructor public * Simplified commands, we need to discuss this in the meeting (what to do with command results?) * Removed all the lex/yacc files * Symbol table is now a templated class, as we will have tables for variables, predicates and functions * The ANTLR parsing infrastructure/makefiles is all in. SMT lib Boolean benchmarks should parse + giving nice error such as Parse Error: /home/dejan/eclipse-cxx/smtlib-parser/test/test4.smt:3:16: Undeclared variable p Parse Error: /home/dejan/eclipse-cxx/smtlib-parser/test/test2.smt:2:11: unexpected token: sa Didn't add any unit tests as the unit testing doesn't work with the updated build system -- it doesn't know how to create directories in the corresponding build directory. TODO: * add the PL grammar and unit test when the testing becomes available * with this build setup my eclipse debugger doesn't work. Might have something to do with the visibility of symbols? * i'm getting g++ depracated warnings regarding the hash_map from the symbol table, need to figure out how to use it in a standard manner. the new <unordered_map> header is for C++0x, and the <ext/hash_map> is getting deprecation warningns... weird.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 4 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index f4320aeb4..e6ad11733 100644
--- a/configure.ac
+++ b/configure.ac
@@ -257,17 +257,7 @@ AM_PROG_LEX
AC_PROG_YACC
# Check for ANTLR runantlr script (defined in config/antlr.m4)
-AC_ARG_ENABLE(antlr, AS_HELP_STRING([--enable-antlr],[use Dejan's ANTLR parsers]))
-AC_MSG_CHECKING([whether you want to use the ANTLR parsers])
-if test -z "${enable_antlr+set}"; then
- enable_antlr=no
-fi
-AC_MSG_RESULT([$enable_antlr])
-AM_CONDITIONAL(USE_ANTLR, test "$enable_antlr" = yes)
-if test "$enable_antlr" = yes; then
- AC_PROG_ANTLR
- AC_DEFINE(ANTLR_PARSERS, [], [whether we're using ANTLR parsers])
-fi
+AC_PROG_ANTLR
AC_CHECK_PROG(DOXYGEN, doxygen, doxygen, [])
if test -z "$DOXYGEN"; then
@@ -310,9 +300,8 @@ fi
# Checks for libraries.
AC_CHECK_LIB(gmp, __gmpz_init, , [AC_MSG_ERROR([GNU MP not found, see http://gmplib.org/])])
# Check for antlr C++ runtime (defined in config/antlr.m4)
-if test "$enable_antlr" = yes; then
- AC_LIB_ANTLR
-fi
+AC_LIB_ANTLR
+
# Checks for header files.
AC_CHECK_HEADERS([getopt.h unistd.h])
@@ -398,7 +387,7 @@ CPPFLAGS : $CPPFLAGS
CXXFLAGS : $CXXFLAGS
LDFLAGS : $LDFLAGS
-Using ANTLR parsers : $enable_antlr
+
Library releases : $CVC4_LIBRARY_RELEASE_CODE
libcvc4 version : $CVC4_LIBRARY_VERSION
libcvc4parser version: $CVC4_PARSER_LIBRARY_VERSION
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback